Subject: pgAdmin IV- Testing framework: Enhanced Test Result Summary

From: Navnath Gadakh <[email-masked]>
Date: Fri, 16 Sep 2016 19:07:53 +0530

Hi Dave,
     Please find the patch for the enhanced test result summary for testing
framework. The code for this, was completed before drop object's
functionality & independent from drop objects work.
Drop objects work will take time, I am working on that for remaining
nodes. Meanwhile,
we go ahead with enhanced test summary.

*To run the test suite follow the commands*
1. python regression/runtests.py --pkg browser.server_groups.servers
2. python regression/runtests.py --pkg
browser.server_groups.servers.databases

-- 
Thanks,
Navnath Gadakh
Software Engineer
EnterpriseDB Corporation
Mobile: +91 9975389878

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 16 Sep 2016 16:53:37 +0100

Hi

On Fri, Sep 16, 2016 at 2:37 PM, Navnath Gadakh
<[email-masked]> wrote:
> Drop objects work will take time, I am working on that for remaining nodes.
> Meanwhile, we go ahead with enhanced test summary.
>
> To run the test suite follow the commands

I'm seeing some issues with this patch:

- There are updates to config.py and setup.py that shouldn't be there.
- I get this error at the end of a successful test run:

Test Result Summary
============================
Regression - PG 9.4: 25 tests passed, 0 tests failed
============================

Please check output in file:
/Users/dpage/git/pgadmin4/web/regression/regression.log
Error in atexit._run_exitfuncs:
Traceback (most recent call last):
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/atexit.py",
line 24, in _run_exitfuncs
    func(*targs, **kargs)
  File "/Users/dpage/git/pgadmin4/web/regression/test_utils.py", line
360, in drop_objects
    file_name, sys.exc_traceback.tb_lineno, exception))
Exception: test_utils.py: line:337 'NoneType' object has no attribute
'__getitem__'
Error in sys.exitfunc:
Traceback (most recent call last):
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/atexit.py",
line 24, in _run_exitfuncs
    func(*targs, **kargs)
  File "/Users/dpage/git/pgadmin4/web/regression/test_utils.py", line
360, in drop_objects
    file_name, sys.exc_traceback.tb_lineno, exception))
Exception: test_utils.py: line:337 'NoneType' object has no attribute
'__getitem__'

-- 
Dave Page
VP, Chief Architect, Tools & Installers
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

---

From: Navnath Gadakh <[email-masked]>
Date: Mon, 19 Sep 2016 12:44:11 +0530

Hi Dave,
    Error resolved. Please find the revised patch.

On Fri, Sep 16, 2016 at 9:23 PM, Dave Page <[email-masked]>
wrote:

> nodes.
  Thanks.

-- 
Regards,
Navnath

---

From: Dave Page <[email-masked]>
Date: Mon, 19 Sep 2016 09:33:56 +0100

Hi

>     Error resolved. Please find the revised patch.

I still see the error:

Test Result Summary

---

From: Navnath Gadakh <[email-masked]>
Date: Mon, 19 Sep 2016 18:33:52 +0530

Hi Dave,
      In the drop objects function scenario for 'NoneType' was not handled.
Code is added in the revised patch.

Thanks.

-- 
Regards,
Navnath

---

From: Dave Page <[email-masked]>
Date: Mon, 19 Sep 2016 16:50:22 +0100

Thanks - applied with minor tweaks to the output formatting.

On Mon, Sep 19, 2016 at 2:03 PM, Navnath Gadakh
<[email-masked]> wrote:
>>   File
>> "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/atexit.py",
>>   File
>> "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/atexit.py",