Subject: Re: Alertify Dialog (CSS)

From: Arun Kollan <[email-masked]>
Date: Fri, 15 Apr 2016 15:14:13 +0100

Hi Team,
 Please find attached the patch for preferences alert dialogue . I had to make some change to the preferences js to accommodate font awesome icons onto alert buttons. There is an issue with the button on preferences being active only if you click on the icons. I am trying to find a work around to generate events on the button labels. 

The icons on the bare alert dialogues buttons does not display the icons yet as it is not customised. 

Regards,

Arun Kollan
Website: www.enterprisedb.com <http://www.enterprisedb.com/>
EnterpriseDB Blog: http://blogs.enterprisedb.com/ <http://blogs.enterprisedb.com/>
Follow us on Twitter: http://www.twitter.com/enterprisedb <http://www.twitter.com/enterprisedb>

This e-mail message (and any attachment) is intended for the use of the individual or entity to whom it is addressed. This message contains information from EnterpriseDB Corporation that may be privileged, confidential, or exempt from disclosure under applicable law. If you are not the intended recipient or authorized to receive this for the intended recipient, any use, dissemination, distribution, retention, archiving, or copying of this communication is strictly prohibited. If you have received this e-mail in error, please notify the sender immediately by reply e-mail and delete this message.

> On 14 Apr 2016, at 11:23, Dave Page <[email-masked]> wrote:
> 
> For Ashesh: this is looking excellent. Arun has a handful of minor issues to fix and will submit the patch.
> 
> On Wed, Apr 13, 2016 at 2:25 PM, Arun Kollan <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Dave/Ashesh,
> Please find attached the patch for alert dialogue styling. I have used the patch from Ashesh and modified with the style to be consistent with the application. I have not sent the patch yet to pgadmin hackers as I thought to get some feedback before I do. 
> 
> 
> 
> 
> Regards,
> Arun Kollan
> Website: www.enterprisedb.com <http://www.enterprisedb.com/>
> EnterpriseDB Blog: http://blogs.enterprisedb.com/ <http://blogs.enterprisedb.com/>
> Follow us on Twitter: http://www.twitter.com/enterprisedb <http://www.twitter.com/enterprisedb>
> 
> This e-mail message (and any attachment) is intended for the use of the individual or entity to whom it is addressed. This message contains information from EnterpriseDB Corporation that may be privileged, confidential, or exempt from disclosure under applicable law. If you are not the intended recipient or authorized to receive this for the intended recipient, any use, dissemination, distribution, retention, archiving, or copying of this communication is strictly prohibited. If you have received this e-mail in error, please notify the sender immediately by reply e-mail and delete this message.
> 
> 
> 
> 
>> On 6 Apr 2016, at 15:17, Arun Kollan <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Ashesh,
>>  Just to let you know that I am working on styling the alert dialogue based on the patch you have sent.
>> 
>> Thank you. 
>> Arun Kollan
>> Website: www.enterprisedb.com <http://www.enterprisedb.com/>
>> EnterpriseDB Blog: http://blogs.enterprisedb.com/ <http://blogs.enterprisedb.com/>
>> Follow us on Twitter: http://www.twitter.com/enterprisedb <http://www.twitter.com/enterprisedb>
>> 
>> This e-mail message (and any attachment) is intended for the use of the individual or entity to whom it is addressed. This message contains information from EnterpriseDB Corporation that may be privileged, confidential, or exempt from disclosure under applicable law. If you are not the intended recipient or authorized to receive this for the intended recipient, any use, dissemination, distribution, retention, archiving, or copying of this communication is strictly prohibited. If you have received this e-mail in error, please notify the sender immediately by reply e-mail and delete this message.
>> 
>> 
>> 
>> 
>>> On 5 Apr 2016, at 09:25, Dave Page <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> I think it's a definite improvement - clearly there's still improvements to be made, but it's a good step forward.
>>> 
>>> On Thu, Mar 31, 2016 at 3:03 PM, Ashesh Vashi <[email-masked] <mailto:[email-masked]>> wrote:
>>> Hi Dave/Arun,
>>> 
>>> I tried to play around with the CSS of alertify dialog, and come up with this.
>>> Please take a look at it.
>>> 
>>> --
>>> Thanks & Regards,
>>> 
>>> Ashesh Vashi
>>> EnterpriseDB INDIA: Enterprise PostgreSQL Company <http://www.enterprisedb.com/>
>>> 
>>> http://www.linkedin.com/in/asheshvashi <http://www.linkedin.com/in/asheshvashi>
>>> 
>>> 
>>> -- 
>>> Dave Page
>>> VP, Chief Architect, Tools & Installers
>>> EnterpriseDB: http://www.enterprisedb.com <http://www.enterprisedb.com/>
>>> The Enterprise PostgreSQL Company
>>> 
>>> Blog: http://pgsnake.blogspot.com <http://pgsnake.blogspot.com/>
>>> Twitter: @pgsnake
>> 
> 
> 
> 
> 
> 
> -- 
> Dave Page
> VP, Chief Architect, Tools & Installers
> EnterpriseDB: http://www.enterprisedb.com <http://www.enterprisedb.com/>
> The Enterprise PostgreSQL Company
> 
> Blog: http://pgsnake.blogspot.com <http://pgsnake.blogspot.com/>
> Twitter: @pgsnake

---

From: Dave Page <[email-masked]>
Date: Fri, 15 Apr 2016 15:32:04 +0100

Thanks - applied.

There are still some minor issues to resolve which Arun will continue to
work on;

- Status bar height
- Button height
- Sizing of the X in the close button.

On Fri, Apr 15, 2016 at 3:14 PM, Arun Kollan <[email-masked]>
wrote:

> Hi Team,
>  Please find attached the patch for preferences alert dialogue . I had to
> make some change to the preferences js to accommodate font awesome icons
> onto alert buttons. There is an issue with the button on preferences being
> active only if you click on the icons. I am trying to find a work around to
> generate events on the button labels.
>
> *Website: www.enterprisedb.com <http://www.enterprisedb.com>*
>
> *EnterpriseDB Blog: http://blogs.enterprisedb.com/
> <http://blogs.enterprisedb.com/>Follow us on
> Twitter: http://www.twitter.com/enterprisedb
> <http://www.twitter.com/enterprisedb>*
>
> This e-mail message (and any attachment) is intended for the use of the
> individual or entity to whom it is addressed. This message contains
> information from EnterpriseDB Corporation that may be privileged,
> confidential, or exempt from disclosure under applicable law. If you are
> not the intended recipient or authorized to receive this for the intended
> recipient, any use, dissemination, distribution, retention, archiving, or
> copying of this communication is strictly prohibited. If you have received
> this e-mail in error, please notify the sender immediately by reply e-mail
> and delete this message.
>
>
>
>
> On Wed, Apr 13, 2016 at 2:25 PM, Arun Kollan <[email-masked]
> > wrote:
>
>> Hi Dave/Ashesh,
>> Please find attached the patch for alert dialogue styling. I have used
>> the patch from Ashesh and modified with the style to be consistent with the
>> application. I have not sent the patch yet to pgadmin hackers as I thought
>> to get some feedback before I do.
>>
>>
>>
>>
>> Regards,
>> Arun Kollan
>> *Website: www.enterprisedb.com <http://www.enterprisedb.com/>*
>>
>> *EnterpriseDB Blog: http://blogs.enterprisedb.com/
>> <http://blogs.enterprisedb.com/>Follow us on
>> Twitter: http://www.twitter.com/enterprisedb
>> <http://www.twitter.com/enterprisedb>*
>>
>> This e-mail message (and any attachment) is intended for the use of the
>> individual or entity to whom it is addressed. This message contains
>> information from EnterpriseDB Corporation that may be privileged,
>> confidential, or exempt from disclosure under applicable law. If you are
>> not the intended recipient or authorized to receive this for the intended
>> recipient, any use, dissemination, distribution, retention, archiving, or
>> copying of this communication is strictly prohibited. If you have received
>> this e-mail in error, please notify the sender immediately by reply e-mail
>> and delete this message.
>>
>>
>>
>>
>> On 6 Apr 2016, at 15:17, Arun Kollan <[email-masked]>
>> wrote:
>>
>> Hi Ashesh,
>> *Website: www.enterprisedb.com <http://www.enterprisedb.com/>*
>>
>> *EnterpriseDB Blog: http://blogs.enterprisedb.com/
>> <http://blogs.enterprisedb.com/>Follow us on
>> Twitter: http://www.twitter.com/enterprisedb
>> <http://www.twitter.com/enterprisedb>*
>>
>> This e-mail message (and any attachment) is intended for the use of the
>> individual or entity to whom it is addressed. This message contains
>> information from EnterpriseDB Corporation that may be privileged,
>> confidential, or exempt from disclosure under applicable law. If you are
>> not the intended recipient or authorized to receive this for the intended
>> recipient, any use, dissemination, distribution, retention, archiving, or
>> copying of this communication is strictly prohibited. If you have received
>> this e-mail in error, please notify the sender immediately by reply e-mail
>> and delete this message.
>>
>>
>>
>>
>> On 5 Apr 2016, at 09:25, Dave Page <[email-masked]> wrote:
>>
>> I think it's a definite improvement - clearly there's still improvements
>> to be made, but it's a good step forward.
>>
>> On Thu, Mar 31, 2016 at 3:03 PM, Ashesh Vashi <
>> [email-masked]> wrote:
>>
>>> Hi Dave/Arun,
>>>
>>> *http://www.linkedin.com/in/asheshvashi*
>>> <http://www.linkedin.com/in/asheshvashi>
>>>
>>
>>
>>
>> --
>> Dave Page
>> EnterpriseDB: http://www.enterprisedb.com
>> Blog: http://pgsnake.blogspot.com
>> Twitter: @pgsnake
>>
>>
>>
>>
>>
>
>
> --
> Dave Page
> EnterpriseDB: http://www.enterprisedb.com
> Blog: http://pgsnake.blogspot.com
> Twitter: @pgsnake
>
>
>
>

-- 
Dave Page
VP, Chief Architect, Tools & Installers
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

---

From: Dave Page <[email-masked]>
Date: Sat, 16 Apr 2016 10:04:13 +0100

Hi Arun

Please also check the styling of the Grant Wizard (which uses a generic
wizard framework based on Alertify). That seems to be overriding some of
your styling in a nasty way.

Thanks.

On Friday, April 15, 2016, Dave Page <[email-masked]> wrote:

> On Fri, Apr 15, 2016 at 3:14 PM, Arun Kollan <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
>> Hi Team,
>> On 14 Apr 2016, at 11:23, Dave Page <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>
>>> Hi Dave/Ashesh,
>>> On 6 Apr 2016, at 15:17, Arun Kollan <[email-masked]
>>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>>
>>> Hi Ashesh,
>>> On 5 Apr 2016, at 09:25, Dave Page <[email-masked]
>>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>>
>>> [email-masked]
>>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>>
>>>> Hi Dave/Arun,
>>>>

---

From: Arun Kollan <[email-masked]>
Date: Sat, 16 Apr 2016 17:23:21 +0100

Sure Dave. I will send over a patch.

Regards,
Arun
> On 16 Apr 2016, at 10:04, Dave Page <[email-masked]> wrote:
> 
> Hi Arun
> 
> Please also check the styling of the Grant Wizard (which uses a generic wizard framework based on Alertify). That seems to be overriding some of your styling in a nasty way.
> 
> Thanks.
> 
> On Friday, April 15, 2016, Dave Page <[email-masked] <mailto:[email-masked]>> wrote:
> Thanks - applied.
> 
> There are still some minor issues to resolve which Arun will continue to work on;
> 
> - Status bar height
> - Button height
> On Fri, Apr 15, 2016 at 3:14 PM, Arun Kollan <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
> Hi Team,
>> On 14 Apr 2016, at 11:23, Dave Page <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>> 
>> On Wed, Apr 13, 2016 at 2:25 PM, Arun Kollan <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>> Hi Dave/Ashesh,
>>> On 6 Apr 2016, at 15:17, Arun Kollan <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>> 
>>> Hi Ashesh,
>>>> On 5 Apr 2016, at 09:25, Dave Page <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>>> 
>>>> On Thu, Mar 31, 2016 at 3:03 PM, Ashesh Vashi <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>>> Hi Dave/Arun,
>>>>