Subject: Relax version dependency on psycopg2

From: Magnus Hagander <[email-masked]>
Date: Tue, 9 May 2017 13:28:17 +0200

Right now psycopg2 is required to be exactly version 2.6.2, which makes it
mostly impossible to install pgadmin4 without having the postgresql C
development packages installed (since you need to rebuild psycopg2 from
source to make that work, given that few platforms ship *exactly* that
version).

I suggest just saying "2.6 or greater", which should make it work on many
more platforms.

AFAIK there aren't any other packages with similar compile requirements, so
the rest seem OK.

-- 
 Magnus Hagander
 Me: https://www.hagander.net/ <http://www.hagander.net/>
 Work: https://www.redpill-linpro.com/ <http://www.redpill-linpro.com/>
diff --git a/requirements.txt b/requirements.txt
index 90ed057..deb8bde 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -27,7 +27,7 @@ MarkupSafe==0.23
 ordereddict; python_version < '2.7'
 passlib==1.6.2
 pbr==1.9.1
-psycopg2==2.6.2
+psycopg2>=2.6.2
 pycrypto==2.6.1
 pyrsistent==0.11.13
 python-dateutil==2.5.0

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Tue, 9 May 2017 12:32:30 +0100

Thanks, patch applied.

On Tue, May 9, 2017 at 12:28 PM, Magnus Hagander <[email-masked]>
wrote:

> AFAIK there aren't any other packages with similar compile requirements,
> so the rest seem OK.
>
> --
>  Magnus Hagander

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company