Subject: [PATCH] Document that a patch should be submitted to the list as an attachment

From: Chris Mayo <[email-masked]>
Date: Mon, 10 Oct 2016 19:40:42 +0100

Signed-off-by: Chris Mayo <[email-masked]>
---
 docs/en_US/submitting_patches.rst | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/docs/en_US/submitting_patches.rst b/docs/en_US/submitting_patches.rst
index c077551..4ac878d 100644
--- a/docs/en_US/submitting_patches.rst
+++ b/docs/en_US/submitting_patches.rst
@@ -30,7 +30,7 @@ to create a patch between your development branch and the public master branch.
 
 Once you have your patch, check it thoroughly to ensure it meets the pgAdmin
 :doc:`coding_standards`, and review it against the :doc:`code_review` to minimise
-the chances of it being rejected. Once you're happy with your work, mail it to the 
-mailing list [email-masked]. Please ensure you include a full 
-description of what the patch does, as well as the rationale for any important 
-design decisions.
+the chances of it being rejected. Once you're happy with your work, mail it
+as an attachment to the mailing list [email-masked].
+Please ensure you include a full description of what the patch does,
+as well as the rationale for any important design decisions.

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Tue, 11 Oct 2016 15:34:54 +0100

Hi

On Monday, October 10, 2016, Chris Mayo <[email-masked]> wrote:

> Signed-off-by: Chris Mayo <[email-masked] <javascript:;>>
> ---
This doesn't apply - can you rebase it please?

Thanks.

(pgadmin4)snake:pgadmin4 dpage$ git apply
~/Downloads/0001-Document-that-a-patch-should-be-submitted-to-the-lis.patch
/Users/dpage/Downloads/0001-Document-that-a-patch-should-be-submitted-to-the-lis.patch:13:
trailing whitespace.
the chances of it being rejected. Once you're happy with your work, mail it
/Users/dpage/Downloads/0001-Document-that-a-patch-should-be-submitted-to-the-lis.patch:14:
trailing whitespace.
as an attachment to the mailing list [email-masked].
/Users/dpage/Downloads/0001-Document-that-a-patch-should-be-submitted-to-the-lis.patch:15:
trailing whitespace.
Please ensure you include a full description of what the patch does,
/Users/dpage/Downloads/0001-Document-that-a-patch-should-be-submitted-to-the-lis.patch:16:
trailing whitespace.
as well as the rationale for any important design decisions.
error: patch failed: docs/en_US/submitting_patches.rst:30
error: docs/en_US/submitting_patches.rst: patch does not apply

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Chris Mayo <[email-masked]>
Date: Tue, 11 Oct 2016 18:14:46 +0100

On 11/10/16 15:34, Dave Page wrote:
> Hi
> 
> On Monday, October 10, 2016, Chris Mayo <[email-masked] <mailto:[email-masked]>> wrote:
> 
> (pgadmin4)snake:pgadmin4 dpage$ git apply ~/Downloads/0001-Document-that-a-patch-should-be-submitted-to-the-lis.patch 
> /Users/dpage/Downloads/0001-Document-that-a-patch-should-be-submitted-to-the-lis.patch:13: trailing whitespace.
> /Users/dpage/Downloads/0001-Document-that-a-patch-should-be-submitted-to-the-lis.patch:14: trailing whitespace.
> as an attachment to the mailing list [email-masked] <mailto:[email-masked]>.
> /Users/dpage/Downloads/0001-Document-that-a-patch-should-be-submitted-to-the-lis.patch:15: trailing whitespace.
> /Users/dpage/Downloads/0001-Document-that-a-patch-should-be-submitted-to-the-lis.patch:16: trailing whitespace.

I checked and I can't see anything wrong. I also tried downloading the patch from the web archive and using git apply.

The "trailing whitespace" errors may suggest the problem - the added lines in the patch don't have any whitespace.
Have you been near a Windows machine? I used unix2dos on the patch and then got the same result as above.

Chris

---

From: Dave Page <[email-masked]>
Date: Tue, 11 Oct 2016 22:03:06 +0100

Hi

On Tuesday, October 11, 2016, Chris Mayo <[email-masked]> wrote:

> > On Monday, October 10, 2016, Chris Mayo <[email-masked]
> <javascript:;> <mailto:[email-masked] <javascript:;>>> wrote:
> >
> >     Signed-off-by: Chris Mayo <[email-masked] <javascript:;>
> <javascript:;>>
> >     ---
> > (pgadmin4)snake:pgadmin4 dpage$ git apply ~/Downloads/0001-Document-
> that-a-patch-should-be-submitted-to-the-lis.patch
> > /Users/dpage/Downloads/0001-Document-that-a-patch-should-
> be-submitted-to-the-lis.patch:13: trailing whitespace.
> > /Users/dpage/Downloads/0001-Document-that-a-patch-should-
> be-submitted-to-the-lis.patch:14: trailing whitespace.
> > as an attachment to the mailing list [email-masked]
> <javascript:;> <mailto:[email-masked] <javascript:;>>.
> > /Users/dpage/Downloads/0001-Document-that-a-patch-should-
> be-submitted-to-the-lis.patch:15: trailing whitespace.
> > /Users/dpage/Downloads/0001-Document-that-a-patch-should-
> be-submitted-to-the-lis.patch:16: trailing whitespace.
> I checked and I can't see anything wrong. I also tried downloading the
> patch from the web archive and using git apply.
>

No, I've only been on my Mac. Your suggestion made me think though - I
opened the patch in my editor, and it claims the original had Windows line
endings. I converted them to \n and it applied just fine.

What does 'git config core.autocrlf' output for you?

In any case, I applied the patch. Thanks!

---

From: Chris Mayo <[email-masked]>
Date: Wed, 12 Oct 2016 12:33:52 +0100

> No, I've only been on my Mac. Your suggestion made me think though - I opened the patch in my editor, and it claims the original had Windows line endings. I converted them to \n and it applied just fine.

I think it's an email thing. From:
https://github.com/git/git/commit/8d8140843501107c92e2f9a5acb60ee136352c1f
"The problem is that SMTP transport is CRLF-unsafe.  Sending a patch by
email is the same as passing it through "dos2unix | unix2dos".  The newly
introduced CRLFs are normally transparent because git-am strips them."

I have been using git send-email, to avoid the risk of a mail client mangling patches.
But I can try using Thunderbird in future.

I guess git imap-send behaviour is similar:
http://www.spinics.net/lists/git/msg160136.html
"
> I'm using git imap-send to send patches to wine-patches, and it seems
> like it converts all my patches to have CRLF line endings?

The canonical line ending for mail is CRLF. So yes, it will convert your
patch to CRLF for storage. But anything pulling it out of the IMAP
folder should convert it back to native line endings."

Testing locally the raw emails do have CRLF saved from Thunderbird as .eml,
although when I save just the attachment the patch only has LF.

Not sure why this hasn't been an issue before on the list.

The Git tools seem to be more focussed on inline messages. On the receiving end 
using attachments the ideas I have:
 - Is there a save as text option in your client?
 - Save from the web archive

> What does 'git config core.autocrlf' output for you?

The only core. attribute I have set is core.editor.

> In any case, I applied the patch. Thanks!

Hopefully we don't have to add more instructions as a result of this discussion...

Chris

---

From: Dave Page <[email-masked]>
Date: Wed, 12 Oct 2016 15:06:20 +0100

Hi

On Wednesday, October 12, 2016, Chris Mayo <[email-masked]> wrote:

> >     I checked and I can't see anything wrong. I also tried downloading
> the patch from the web archive and using git apply.
> >
> >     The "trailing whitespace" errors may suggest the problem - the added
> lines in the patch don't have any whitespace.

It has, on rare occasions. One particular friend of mine had to resort to
gzipping patches for pgAdmin 4, but it's been a non-issue for pretty much
everyone else here - and the process we use is pretty standard on the
PostgreSQL lists as well, where it's also not generally a problem.

Note that at least for those of us at EDB, Gmail is the standard client we
use. I wonder if some combination of sending and receiving MUAs is what
causes the problem.

>  - Is there a save as text option in your client?

You can view the original message in Gmail, but that's the entire raw text
of it, so you get all the mime parts and headers as well.

>  - Save from the web archive

That's a possibility, though it's such a rare issue that I doubt we'll
remember to do it.

I'd really like to know the root cause - it's quite annoying not being able
to pin it down.

> Hopefully we don't have to add more instructions as a result of this

Well at least it's keeping you busy :-)

Thanks, Dave.