Subject: [pgAdmin4][Patch]: Fix for Feature #4334, RM #4496 and #4497

From: Akshay Joshi <[email-masked]>
Date: Wed, 24 Jul 2019 12:39:47 +0530

Hi Hackers,

I have added the support of Generated Columns (PG/EPAS 12) and also fixed
RM #4496, #4497.

During the implementation of that I have also fixed following issues that I
encountered:

   - User should not be able to provide Default value with Identity column.
   - 'Drop Cascade' button to delete multiple columns should be disabled.
   - Set "Not Null?" switch to 'Yes' when we create Identity column.
   - Fix issue when we insert default value for the column and then remove
   it. It generates wrong msql.
   - Fix issue when we provide the default value of a column and then
   select the datatype to serial/bigserial/smallserial, it generates wrong
   msql.

Modified/Added regression test cases for adding Identity column and
Generated columns.
Please review it.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 24 Jul 2019 17:27:51 +0530

Hi Hackers,

Attached is the updated patch with Documentation for Identity/Generated
columns and updated screenshots.
Please ignore the previous patch.

On Wed, Jul 24, 2019 at 12:39 PM Akshay Joshi <[email-masked]>
wrote:

> During the implementation of that I have also fixed following issues that
> I encountered:
>
>    - Fix issue when we insert default value for the column and then
>    remove it. It generates wrong msql.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Dave Page <[email-masked]>
Date: Thu, 25 Jul 2019 16:38:38 +0100

Thanks, patch applied.

On Wed, Jul 24, 2019 at 12:58 PM Akshay Joshi <[email-masked]>
wrote:

> On Wed, Jul 24, 2019 at 12:39 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Hackers,
>>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company