Subject: pgAgent 4.0 patch

From: Dave Page <[email-masked]>
Date: Mon, 4 Jun 2018 17:34:52 +0100

Hi

Can you review the attached please Ashesh?

Thanks.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Ashesh Vashi <[email-masked]>
Date: Tue, 5 Jun 2018 09:37:00 +0530

> Can you review the attached please Ashesh?
Hi Dave,

Due to the wrong pattern in '.gitignore', it was ignoring the new file
'sql/pgagent--3.4--4.0.sql'.
We should ignore only the '*.sql' in the root directory.
Something like this.

*$ git diff .gitignore*
*diff --git a/.gitignore b/.gitignore*
*index 9883354..40fe7a9 100644*
*--- a/.gitignore*
*+++ b/.gitignore*
*@@ -6,7 +6,12 @@ CPackSourceConfig.cmake*
* Makefile*
* cmake_install.cmake*
* install_manifest.txt*
*-pgagent*
*+# Ignore 'pgagent' & 'pgagent.control' in root directory only.*
*+/pgagent*
*+!/*/pgagent*
* pgagent.control*
*+!/*/pgagent.control*
* *.log*
*-*.sql*
*+# Ignore '*.sql' files in root directory only.*
*+/*.sql*
*+!/*/*.sql*

And, I am getting the following warning applying the patch.

*$ git apply ~/Downloads/pgagent-4.0-update.diff*
*/Users/asheshvashi/Downloads/pgagent-4.0-update.diff:320: trailing
whitespace.*
*//*
*warning: 1 line adds whitespace errors.*

Otherwise - it looks good to me.

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com/>

*http://www.linkedin.com/in/asheshvashi
<http://www.linkedin.com/in/asheshvashi>*

---

From: Dave Page <[email-masked]>
Date: Tue, 5 Jun 2018 10:40:35 +0100

Thanks, committed with those changes.

Paresh; can you please create some pgAgent 4.0 installers (PG not EPAS
Bitrock installers) from git head for Fahar to test?

Once he's happy with them, I'll tag and build the community packages.

Thanks!

---

From: Paresh More <[email-masked]>
Date: Thu, 7 Jun 2018 12:09:43 +0530

Hello Fahar,

File, pgagent-4.0.0-1-linux-x64.run is uploaded @
https://uploads.enterprisedb.com/download.php?file=bd89aec08d73ceae21cf560c391598f6

On Tue, Jun 5, 2018 at 3:10 PM, Dave Page <[email-masked]> wrote:

> On Tue, Jun 5, 2018 at 5:07 AM, Ashesh Vashi <
> [email-masked]> wrote:
>

-- 

Thanks & Regards

*Paresh More*

Pune, India.
Cell :  +919922000564 |  www.enterprisedb.com

---

From: Fahar Abbas <[email-masked]>
Date: Thu, 7 Jun 2018 11:46:29 +0500

Hi Paresh,

Thanks for sharing pgagent linux64 installers.

On Thu, Jun 7, 2018 at 11:39 AM, Paresh More <[email-masked]>
wrote:

> Hello Fahar,
>
> File, pgagent-4.0.0-1-linux-x64.run is uploaded @  https://uploads.
> enterprisedb.com/download.php?file=bd89aec08d73ceae21cf560c391598f6
>

-- 
Fahar Abbas
QMG
EnterpriseDB Corporation
Phone Office: +92-51-835-8874
Phone Direct: +92-51-8466803
Mobile: +92-333-5409707
Skype ID: syed.fahar.abbas
Website: www.enterprisedb.com