Subject: Unable to update Domain properly

From: Khushboo Vashi <[email-masked]>
Date: Wed, 13 Jan 2016 18:43:13 +0530

Hi,

While updating Domain from pgAdmin-III  , I observed an error.

When I update only Domain name it is working properly, but when I try to
update multiple fields, I get an error.

For example,  if I try to rename Domain *TestDomain* to *TestDomain1* and
also modifies one or more fields (except comment). I get below error.

ERROR:  type "pem.TestDomain" does not exist

*Generated SQL:*

ALTER DOMAIN pem."TestDomain"
  RENAME TO "TestDomain1";
ALTER DOMAIN pem."TestDomain"
  DROP NOT NULL;

Thanks,
Khushboo

---

From: Neel Patel <[email-masked]>
Date: Wed, 13 Jan 2016 22:57:15 +0530

Hi,

Please find the attached patch file for fix of above issue.

*Issue:- *
Below generated SQL was wrong.

In second query, domain name is wrong as domain name was updated by the
first query.

*Resolution:-*

Now when any properties got changed along with domain name then correct SQL
will be generated.
Correct query should be as below.

ALTER DOMAIN pem."TestDomain"
  RENAME TO "TestDomain1";
ALTER DOMAIN pem."TestDomain1"
  DROP NOT NULL;

Please review it and do let us know for any comment.

Thanks,
Neel Patel

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Neel Patel <[email-masked]>
Date: Thu, 14 Jan 2016 12:11:55 +0530

Hi,

Please find updated patch file with the fix of below issue.

*Issue: -*

Earlier patch file will work only when in "public" schema.
If we change the schema name then generated name should contain both
"<schema_name>"."<domain_name>".
Attached patch file will include the schema name along with domain name.

Thanks Khushboo for point out the issue.

Thanks,
Neel Patel

On Wed, Jan 13, 2016 at 10:57 PM, Neel Patel <[email-masked]>
wrote:

> Now when any properties got changed along with domain name then correct
> SQL will be generated.
>> For example,  if I try to rename Domain *TestDomain* to *TestDomain1*
>> and also modifies one or more fields (except comment). I get below error.
>>
>>