Subject: [pgAdmin3][Extension]: Wrong SQL generated

From: Surinder Kumar <[email-masked]>
Date: Mon, 18 Jan 2016 16:33:36 +0530

Hi all,

While implementing Extension module in pgAdmin4, I came to know that there
is an bug in pgadmin3.

Following are the steps to reproduce it:
1. Edit an existing extension.
2. In definition tab, set schema and version fields to empty.
3. In SQL tab, it generates an sql for the changes made which is wrong, it
shouldn't generate sql for the schema and version field if it is kept
empty, both fields should be validated.

Below is the wrong SQL generated:

*ALTER EXTENSION btree_gin*
*  SET SCHEMA ;*
*ALTER EXTENSION btree_gin*
*  UPDATE TO ;*

Let me know for any comments.

Thanks
Surinder Kumar

---

From: Neel Patel <[email-masked]>
Date: Sun, 24 Jan 2016 19:23:00 +0530

Hi,

Please find attached patch file for the issue mentioned below.

*Issue:- *
When user "Edit" any existing extension module property, and try to change
the schema and version field to blank then SQL should not be generated for
the blank field.

Above issue is fixed with attached patch file.

Do review it and let us know for any comments.

Thanks,
Neel Patel

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers