Subject: Observed bug in pgAdmin3

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 4 Jan 2016 12:28:05 +0530

Hi All,

I observed an issue while creating new collation (in schemas).

Steps to reproduce,
1) Connect to postgres database
2) Expand 'postgres' database
3) Expand 'schemas'
4) Expand 'Collations'
5) Right click & Click "New Collation..."

Provide > Properties:
   Name: test-11
   Owner: postgres
   Schema: pg_toast

Provide > Definition:
   Copy collation: pg_catalog."en_IN.utf8"

6)
Now click on SQL tab and you will see the wrong sql created, schema name 
is appended twice in alter statement.

CREATE COLLATION pg_toast."test-11" FROM pg_catalog."en_IN.utf8";
ALTER COLLATION *pg_toast."pg_toast.""test-11"""*
   OWNER TO postgres;

Let me know for more information.

Regards,
Murtuza Zabuawala

---

From: Neel Patel <[email-masked]>
Date: Sun, 24 Jan 2016 19:17:26 +0530

Hi,

We have fixed the issue as mentioned below.

*Issue :-*
When we create any collation then two times schema name was appended to
query.

*Fix:-*
With this fix, schema name will appended only one time and create query for
collation will execute correctly.

Please find attached patch file. Review it and let us know for any comments.

Thanks,
Neel Patel

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers