Subject: pgAdmin3: check_option translated in View editing dialog

From: Sebastian Albert <[email-masked]>
Date: Wed, 23 Dec 2015 14:25:56 +0100

Dear pgAdmin-Hackers

I observed the following minor issue in pgAdmin3 1.20.0
For I did not find a bugtracker, I'm mailing it to the list. Please
point me to it if there is one.

pgAdmin appears to me translated (into German) in part, probably due
to my locale. However, in the dialog for editing a VIEW's properties,
the generated SQL reads

ALTER VIEW myview
  SET (check_option=nein);

with "Nein", "Lokal" and "Cascaded" offered in the corresponding
dropdown. I can manually edit these two lines away in the SQL tab of
the dialog, but it's probably not intended that way.

- -- Sebastian

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Wed, 23 Dec 2015 13:34:47 +0000

Neel, can you look into this please?

Thanks.

On Wed, Dec 23, 2015 at 1:25 PM, Sebastian Albert
<[email-masked]> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
>
> Dear pgAdmin-Hackers
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v2
>
> iQIcBAEBCAAGBQJWeqDgAAoJEKZN7hpT3kUKC4gP/jCdUy64KlCmGbFH5vOapyCh
> CcicKABS8EtuUpaFEgxPJCemtplSzS9oNzDKBtSKD1MxxoDN/Sjreuw7wYtzmO+/
> U/JIA4rGqP1FgVldXqDuaw4Hih76gRW3XOqTzv+kkqmt/G/0JrKlMDyY9QKPgHw9
> qB2o5Nf9E4QLWyTZkRJqiCuCARsYvHAUWafOINgPx3fpl2cTinSN7/mT8AaLCtXT
> y09MmNvqGp1ILqYp81AsXblPUADdW5rLjcCxD70QIE7ejuej9EtmGYQWLGr8Bo1d
> UnUUQNPuYjrfjInj15Odirmw+hUnfu1iIwjUUze6no4o9FwOmLYx0OKw2gw+QG1H
> byL+JR3wb6H7sa5RgLeNvW90feP7XFsQsKPUREovVNX891ZxGkdNZEknhaL8TYyj
> 8xCqoX9+yecixDA4U9wZIFfsD6b9cNBFRUjOHKLS1qnQ+zQgWQLlUxXAjLiLawgE
> AbB9rf6N9HzLIhVlqd7u/HpNOamUgXrdwBAd7DNiyqqsVdxaOzEFT3bXpgv5UQA/
> F2eyQi35MCzoROcMoVKUT5kVKKo1UcMkymThWV4s78Lv2C7jM+8GX79gcIpGSps5
> mSJLXHLUH03SozfZeGh3DBsl6UyhRHM8GVghCZutHzj68ViM4MSKgPX8RU+wBUxs
> 8ZpeXtC927azi9NJcNP6
> =yrr2
> -----END PGP SIGNATURE-----
>
>
> --

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Neel Patel <[email-masked]>
Date: Wed, 23 Dec 2015 19:09:18 +0530

Hi Dave,

Sure. I will look into this issue.

Thanks,
Neel Patel

---

From: Neel Patel <[email-masked]>
Date: Thu, 24 Dec 2015 16:48:13 +0530

Hi Sebastian,

We have just tried to reproduce the issue but not able to understand the
issue from the description.

We followed below steps.

  1. Change the language to German.
  2. Open the existing View's properties and try to change "With check
option".
  3. Open SQL tab - According to change in option, we are able to see and
edit the query.

Let me know if anything missing in above steps or Can you please give steps
to understand the issue ?

Thanks,
Neel Patel

---

From: Dave Page <[email-masked]>
Date: Thu, 24 Dec 2015 11:20:59 +0000

> to understand the issue ?

Hi Neel,

I believe the issue is that "no" is being translated to "nein" in the SQL:

ALTER VIEW myview
  SET (check_option=nein);

---

From: Sebastian Albert <[email-masked]>
Date: Thu, 24 Dec 2015 12:58:36 +0100

Hi Neel

Thanks for looking into it. Dave is right, it's about the SQL
statement not working (because of translation appearing for a sort of
keyword) *unless* edited manually. You should not *have to* edit the
SQL manually, but due to the issue, you do, no matter what property of
the view you are trying to change.

So, to reproduce:
1. Create a view
2. Set language of pgAdmin to German
3. Try to change anything on the view, e.g., try to rename it, using
the properties dialog.

Unless I edit the SQL statement, I am presented an SQL error, which
comes from the check_option setting being translated.

Happy holidays
Sebastian

On 24.12.2015 12:20, Dave Page wrote:
>> We have just tried to reproduce the issue but not able to 
>> understand the issue from the description.
>> 
>> We followed below steps.
>> 
>> 1. Change the language to German. 2. Open the existing View's 
>> properties and try to change "With check option". 3. Open SQL
>> tab - According to change in option, we are able to see and edit
>> the query.
>> 
>> Let me know if anything missing in above steps or Can you please 
>> give steps to understand the issue ?
> 
> Hi Neel,
> 
> ALTER VIEW myview SET (check_option=nein);
>

---

From: Neel Patel <[email-masked]>
Date: Thu, 24 Dec 2015 17:44:20 +0530

Hi Sebastian,

Thank you for the information. Issue is reproduced with the given steps.
I will submit the patch after the fix.

Thanks,
Neel Patel

On Thu, Dec 24, 2015 at 5:28 PM, Sebastian Albert <
[email-masked]> wrote:

> iQIcBAEBCAAGBQJWe93qAAoJEKZN7hpT3kUKTrgP/1wmrrScAtfvNc269K9+t1sa
> UKyBfyMFvSgcMgydLC6bjsV5ECN2EVeV/qtNy6tGIlpWppzTtXccQxbKvQiwkyT1
> F3MHM6tp869kegB0N2ZU5mzE+8ko/PaFRAISQomSlpxpDsATZ+5nR3VnFnh5DMde
> 4XYbPvdZWH4Kos9yrWDKTxi5FVHbCvj4m86Qxg8hMlOGUixRDlVx77t1dccchEjq
> OJRenlQWO9x65iRQbobXJtJddyQLplulc7enBgSJapQahQ4QTqe4RTx7f4Qya2B8
> 9bIndvgIvbI08cnss7BQ8iJvK737gMoHc9CscwEAwadaI69/2QAlB4wtwS5bwIZp
> DIeW+ulNJC40ZX6Ol/QMNZEvm1pBdwncLAUJBaiHht6M9rJcXld99uEPJDfP5wji
> 2M9WAa3fjyLJFV3d1lA2GYujPgUBAr7KCRcAxgQSXopCj8KICYJzCOkP5skHIPlL
> zYEMDML3uATmMPbabhy65/mf44WgzjebnQwM86iwnPRbWzfzSrWyK26fm+9CZ6aF
> kgZvS9bWtQDViS/+6vTMuR3YQK4H+iU88RCIDbrHa8Kn53S8ryglg1f2CKtqrV9z
> 2bNlK+iCNFxHoz1ApDw0CE8cJTKU31fL/B17+gB/bL6cCtnpzyCjNosRtO7vr89b
> 7N9Y5AOnyVwbQD42/3EN
> =KwP3

---

From: Neel Patel <[email-masked]>
Date: Mon, 28 Dec 2015 16:13:41 +0530

Hi Dave,

I have fixed the issue. Can you please review the attached patch file ? Let
me know for any comments.

@Sebastian - Can you please apply and test the attached patch file ? Let us
know for any issue.

Thanks,
Neel Patel

---

From: Dave Page <[email-masked]>
Date: Wed, 30 Dec 2015 11:05:26 +0000

Ashesh, can you review/commit please? Thanks.

EnterpriseDB UK:http://www.enterprisedb.com
The Enterprise PostgreSQL Company

> On 28 Dec 2015, at 10:43, Neel Patel <[email-masked]> wrote:
> 
> Hi Dave,
> 
> I have fixed the issue. Can you please review the attached patch file ? Let me know for any comments.
> 
> @Sebastian - Can you please apply and test the attached patch file ? Let us know for any issue.
> 
> Thanks,
> Neel Patel
> 
>> On Thu, Dec 24, 2015 at 5:44 PM, Neel Patel <[email-masked]> wrote:
>> Hi Sebastian,
>> 
>>> On Thu, Dec 24, 2015 at 5:28 PM, Sebastian Albert <[email-masked]> wrote:
> <View_Fix.patch>

---

From: Ashesh Vashi <[email-masked]>
Date: Mon, 4 Jan 2016 11:07:38 +0530

> Ashesh, can you review/commit please? Thanks.
Done.

Thanks Sebastian for the report, and Neel for the quick fix.

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>