Subject: pgAdmin 4 commit: Fix unicode handling in the external process tools an

From: Dave Page <[email-masked]>
Date: Tue, 13 Mar 2018 20:45:23 +0000

Fix unicode handling in the external process tools and show the complete command in the process viewer. Fixes #2963. Fixes #3157.

Branch
------
master

Details
-------
https://git.postgresql.org/gitweb?p=pgadmin4.git;a=commitdiff;h=802269910c37a52aa57479bbcc1d8d078f6a88e1
Author: Khushboo Vashi <[email-masked]>

Modified Files
--------------
web/pgadmin/misc/bgprocess/processes.py           | 36 +++++++++++++++++++++--
web/pgadmin/misc/bgprocess/static/js/bgprocess.js |  6 ++--
web/pgadmin/tools/backup/__init__.py              |  5 ++--
3 files changed, 38 insertions(+), 9 deletions(-)

---

From: Joao De Almeida Pereira <[email-masked]>
Date: Tue, 13 Mar 2018 20:54:19 +0000

Hi Dave, Khushboo

Looks like there is a linting issue with this commit:

Successfully installed pycodestyle-2.3.1
 <https://gpdb-dev.data.pivotal.ci/teams/main/pipelines/pgadmin-feature-branches/jobs/pgadmin-master-python-linter/builds/39#L5aa7e5db:6>
/tmp/build/4a5630c2/pgadmin-master/web /tmp/build/4a5630c2
 <https://gpdb-dev.data.pivotal.ci/teams/main/pipelines/pgadmin-feature-branches/jobs/pgadmin-master-python-linter/builds/39#L5aa7e5db:7>
./pgadmin/misc/bgprocess/processes.py:186: [E225] missing whitespace
around operator
 <https://gpdb-dev.data.pivotal.ci/teams/main/pipelines/pgadmin-feature-branches/jobs/pgadmin-master-python-linter/builds/39#L5aa7e5db:8>
./pgadmin/tools/backup/__init__.py:113: [E303] too many blank lines (2)
 <https://gpdb-dev.data.pivotal.ci/teams/main/pipelines/pgadmin-feature-branches/jobs/pgadmin-master-python-linter/builds/39#L5aa7e5db:9>
1       E225 missing whitespace around operator
 <https://gpdb-dev.data.pivotal.ci/teams/main/pipelines/pgadmin-feature-branches/jobs/pgadmin-master-python-linter/builds/39#L5aa7e5db:10>
1       E303 too many blank lines (2)
 <https://gpdb-dev.data.pivotal.ci/teams/main/pipelines/pgadmin-feature-branches/jobs/pgadmin-master-python-linter/builds/39#L5aa7e5db:11>
2

Best Regards,
Victoria & Joao

On Tue, Mar 13, 2018 at 4:45 PM Dave Page <[email-masked]> wrote:

> Fix unicode handling in the external process tools and show the complete
> command in the process viewer. Fixes #2963. Fixes #3157.
>
> Branch
> ------
> master
>
> Details
> -------
>

---

From: Dave Page <[email-masked]>
Date: Tue, 13 Mar 2018 17:30:49 -0400

Thanks - fixed. That begs the question of why Jenkins didn't catch it
though :-/

On Tue, Mar 13, 2018 at 4:54 PM, Joao De Almeida Pereira <
[email-masked]> wrote:

> ./pgadmin/misc/bgprocess/processes.py:186: [E225] missing whitespace around operator

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company