Subject: [pgadmin4][Patch]: Support for create multiple test classes in one test file

From: Akshay Joshi <[email-masked]>
Date: Tue, 12 Jun 2018 19:00:39 +0530

Hi Hackers,

Attached is the patch to create multiple test classes in one test file.

For example: I have one test file *test_feature.py *where I wrote multiple
test classes
    class TestX(BaseTestGenerator):
  class TestY(BaseTestGenerator):
  class TestZ(BaseTestGenerator):

So with current implementation it will run the test cases for *TestZ* class.

-- 
*Akshay Joshi*

*Sr. Software Architect *

*Phone: +91 20-3058-9517Mobile: +91 976-788-8246*

---

From: Joao De Almeida Pereira <[email-masked]>
Date: Tue, 12 Jun 2018 09:42:51 -0400

Hello Hackers,
Instead of doing this change and include more test harnessing to the setup
we have, do you think we can try to push to get pytest into the code base
and all these features will come by default?

Thanks
Joao
​

On Tue, Jun 12, 2018 at 9:30 AM Akshay Joshi <[email-masked]>
wrote:

> For example: I have one test file *test_feature.py *where I wrote
> multiple test classes

---

From: Dave Page <[email-masked]>
Date: Wed, 13 Jun 2018 09:24:56 +0100

> and all these features will come by default?
Agreed.

> Thanks
> Joao
> ​
>
> On Tue, Jun 12, 2018 at 9:30 AM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Hackers,
>>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company