Subject: [pgAdmin4][RM#5261] Support for Collation, FTS Templates, FTS Dictionaries, FTS Configurations and FTS Parsers

From: Akshay Joshi <[email-masked]>
Date: Wed, 18 Mar 2020 16:28:28 +0530

Hi Hackers,

Attached is the patch to add support for Collation, FTS Templates, FTS
Dictionaries, FTS Configurations and FTS Parsers in Schema Diff Tool.

The patch contains some minor fix where parameters are added in the
difference list even though it's size is zero. I have also added the test
cases.

Please review it.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Khushboo Vashi <[email-masked]>
Date: Thu, 19 Mar 2020 13:25:40 +0530

Hi Akshay,

The patch looks good to me.

Apart from this patch, I encountered below error.

"/Users/khushboovashi/Projects/pgadmin4/web/pgadmin/browser/server_groups/servers/databases/schemas/tables/schema_diff_utils.py",
line 271, in get_sql_from_submodule_diff
   parent_target_data=target
 File
"/Users/khushboovashi/Projects/pgadmin4/web/pgadmin/browser/server_groups/servers/databases/schemas/tables/partitions/__init__.py",
line 790, in ddl_compare
   target_data=parent_target_data)
 File
"/Users/khushboovashi/Projects/pgadmin4/web/pgadmin/browser/server_groups/servers/databases/schemas/tables/utils.py",
line 142, in wrap
   return f(*args, **kwargs)
 File
"/Users/khushboovashi/Projects/pgadmin4/web/pgadmin/browser/server_groups/servers/databases/schemas/tables/partitions/__init__.py",
line 508, in get_sql_from_diff
   schema_diff=True)
 File
"/Users/khushboovashi/Projects/pgadmin4/web/pgadmin/browser/server_groups/servers/databases/schemas/tables/utils.py",
line 1369, in get_partitions_sql
   part_data['partition_scheme'] = self.get_partition_scheme(row)
 File
"/Users/khushboovashi/Projects/pgadmin4/web/pgadmin/browser/server_groups/servers/databases/schemas/tables/utils.py",
line 695, in get_partition_scheme
   for row in data[part_keys]:
KeyError: 'partition_keys'

Thanks,
Khushboo

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 19 Mar 2020 14:01:04 +0530

Thanks, Khushboo for review.

> KeyError: 'partition_keys'

   The issue has been fixed and committed.

>
>
>
> Thanks,
> Khushboo
>
> On Wed, Mar 18, 2020 at 4:28 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Hackers,
>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*