Subject: [pgAdmin][RM4061]: Backslashes are not handled correctly for SQL_ASCII database in View/Edit table data

From: Pradip Parkale <[email-masked]>
Date: Tue, 27 Oct 2020 15:26:00 +0530

Hi Hackers,

Please find the attached for RM4061. Backslashes were not handled
correctly for SQL_ASCII database.

-- 
Thanks & Regards,
Pradip Parkale
Software Engineer | EnterpriseDB Corporation

---

From: Khushboo Vashi <[email-masked]>
Date: Wed, 28 Oct 2020 15:02:48 +0530

Hi Pradip,

With this patch, 4061 is getting fixed but if you enter "zażółć", then it
is getting displayed as "zaż\xf3łć". So, the fix is not proper.

Also, if you want to change the typecast, then change the dict which is
mapped for Postgres, Python and Typecast encoding in encoding.py file.

Thanks,
Khushboo