Subject: 4.1 bytecompile error on RHEL 7

From: Devrim Gündüz <[email-masked]>
Date: Wed, 23 Jan 2019 17:08:20 +0000

Hi,

I'm seeing this at the end of the RPM build process on RHEL 7. Please note that
3.6 passes here:

==============================================
+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
Bytecompiling .py files below /var/lib/pgsql/rpm11/BUILDROOT/pgadmin4-4.1-
1.rhel7.x86_64/usr/lib/python2.7 using /usr/bin/python2.7
Compiling /var/lib/pgsql/rpm11/BUILDROOT/pgadmin4-4.1-
1.rhel7.x86_64/usr/lib/python2.7/site-packages/pgadmin4-
web/pgadmin/feature_tests/xss_checks_panels_and_query_tool_test.py ...
  File "/usr/lib/python2.7/site-packages/pgadmin4-
web/pgadmin/feature_tests/xss_checks_panels_and_query_tool_test.py", line 79
    file=sys.stderr, end=""
        ^
SyntaxError: invalid syntax

==============================================

Any ideas?

Regards,

-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Khushboo Vashi <[email-masked]>
Date: Thu, 24 Jan 2019 10:24:25 +0530

Any ideas?
>
> This is the issue only on Python 2.7. Let me fix it in pgAdmin 4.

---

From: Khushboo Vashi <[email-masked]>
Date: Wed, 23 Jan 2019 21:42:50 -0800

>> This is the issue only on Python 2.7. Let me fix it in pgAdmin 4.
The fix has been sent to the pgAdmin hackers.

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 25 Jan 2019 10:43:07 +0000

Hi Khushboo,

> The fix has been sent to the pgAdmin hackers.

Applied the patch, and built packages. Thanks a lot for the quick fix.

Cheers,