Subject: [pgAdmin4][Patch] - RM 2186 - Support external authentication sources [LDAP]

From: Khushboo Vashi <[email-masked]>
Date: Tue, 17 Mar 2020 14:25:38 +0530

Hi,

Please find the attached patch to support LDAP Authentication in Server
mode.
To test the patch, config_auth.py needs to be configured for LDAP
configurations. The config settings are explained in this file in detail.
After configuring the parameters, start the pgadmin server in Server mode
and connect with LDAP server with the valid user via login page.

I have tested this patch with ldap and ldap + ssl/tls. With the TLS, I have
used the default config of ldap3 without certificates.

@Dave, can you please review this patch, as you have a better understanding
of LDAP and you can easily pointed out if I have missed anything.

Note: For the document update I will create the task and assign to Nidhi
for the same.

Thanks,
Khushboo

---

From: navnath gadakh <[email-masked]>
Date: Tue, 17 Mar 2020 15:36:47 +0530

Hi Khushboo,
       I think there is no use of

+    if app is not None:
+        AuthSourceRegistry.load_auth_sources()
+

in get_auth_sources() function.

On Tue, Mar 17, 2020 at 2:25 PM Khushboo Vashi <
[email-masked]> wrote:

> I have tested this patch with ldap and ldap + ssl/tls. With the TLS, I
> have used the default config of ldap3 without certificates.
>
> @Dave, can you please review this patch, as you have a better
> understanding of LDAP and you can easily pointed out if I have missed
> anything.
>

-- 
*-- Navnath*

---

From: Dave Page <[email-masked]>
Date: Tue, 17 Mar 2020 10:12:01 +0000

Hi

30 second read of the first version of the patch...

- Please move the configuration into config.py. Users should never have to
modify a distributed file (it messes up packaging). I don't see any reason
to use a different file just for auth config.

- I think all config options should be prefixed with LDAP_ as we may have
things like CERT_FILE for other purposes too.

- I don't see any test cases.

Thanks.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Khushboo Vashi <[email-masked]>
Date: Tue, 17 Mar 2020 15:53:57 +0530

Hi Dave,

Thanks for the review.

On Tue, Mar 17, 2020 at 3:42 PM Dave Page <[email-masked]> wrote:

> There are many settings for the LDAP, and in the future we will add other
external sources also, so I thought it would be better if we have different
file for the authentication.

> Sure.

> I will think about this, as right now no idea how to write test cases for
this.

Khushboo

---

From: Khushboo Vashi <[email-masked]>
Date: Tue, 17 Mar 2020 15:54:32 +0530

Hi Navnath,

On Tue, Mar 17, 2020 at 3:37 PM navnath gadakh <
[email-masked]> wrote:

> Thanks for the review, I will look into it.

Thanks,
Khushboo

---

From: Dave Page <[email-masked]>
Date: Tue, 17 Mar 2020 10:41:15 +0000

Hi

On Tue, Mar 17, 2020 at 10:24 AM Khushboo Vashi <
[email-masked]> wrote:

>> - Please move the configuration into config.py. Users should never have
>> to modify a distributed file (it messes up packaging). I don't see any
>> reason to use a different file just for auth config.
>>

Sure, but our config file is small compared to many. Splitting things out
is more confusing for users. If they want to do that themselves of course,
they can add a config_local.py file which includes other files as needed.

>> I will think about this, as right now no idea how to write test cases for

It should be fairly straightforward to write tests for some of the
functions in the auth classes. For testing the actual LDAP stuff, we
probably need to add LDAP config options to test_config.json, and only if
present, run the tests. That would probably need to support a list of LDAP
servers, so we can test with different configurations (LDAP, LDAPS,
LDAP_STARTTLS, AD etc).

---

From: Khushboo Vashi <[email-masked]>
Date: Tue, 24 Mar 2020 10:29:42 +0530

Hi,

Please find the attached updated patch.

On Tue, Mar 17, 2020 at 4:11 PM Dave Page <[email-masked]> wrote:

>>> There are many settings for the LDAP, and in the future we will add
>> other external sources also, so I thought it would be better if we have
>> different file for the authentication.
>>
>
Fixed.

> Done.

>>> I will think about this, as right now no idea how to write test cases
>> for this.
>>
>
Done.

Thanks,
Khushboo

>>>> Note: For the document update I will create the task and assign to
>>>> Nidhi for the same.
>>>>
>>>> Thanks,
>>>> Khushboo
>>>>
>>>
>>>
>>> --
>>> Dave Page

---

From: Khushboo Vashi <[email-masked]>
Date: Tue, 24 Mar 2020 10:32:23 +0530

Please disregard my previous patch, attached the updated patch.

On Tue, Mar 24, 2020 at 10:29 AM Khushboo Vashi <
[email-masked]> wrote:

>>> - I think all config options should be prefixed with LDAP_ as we may
>>>> have things like CERT_FILE for other purposes too.
>>>>
>>>> Sure.
>>>
>> Done.
>
>>>>> Please find the attached patch to support LDAP Authentication in
>>>>> Server mode.

---

From: Khushboo Vashi <[email-masked]>
Date: Tue, 24 Mar 2020 15:20:04 +0530

Please disregard my previous patch, attached the updated patch. :)

On Tue, Mar 24, 2020 at 10:32 AM Khushboo Vashi <
[email-masked]> wrote:

>>>>> - Please move the configuration into config.py. Users should never
>>>>> have to modify a distributed file (it messes up packaging). I don't see any
>>> Sure, but our config file is small compared to many. Splitting things
>>> out is more confusing for users. If they want to do that themselves of
>>> course, they can add a config_local.py file which includes other files as
>>> needed.
>>>
>> Fixed.
>>
>>>
>>>
>>>>>> I have tested this patch with ldap and ldap + ssl/tls. With the TLS,
>>>>>> I have used the default config of ldap3 without certificates.
>>>>>>

---

From: Khushboo Vashi <[email-masked]>
Date: Wed, 1 Apr 2020 17:38:39 +0530

Hi,

Please find the attached updated patch which includes the review comments
given in the review meeting:

1. Do not store password for ldap user in sqlite database
2. Forgot Password : Give error to ldap users
3. User Management dialog changes
4. Authentication source display besides username / email after login

Thanks,
Khushboo

---

From: Khushboo Vashi <[email-masked]>
Date: Thu, 2 Apr 2020 14:06:47 +0530

Hi,

Resending the patch.
Missed the requirements.txt file in the previous patch.

Thanks,
Khushboo

On Wed, Apr 1, 2020 at 5:38 PM Khushboo Vashi <
[email-masked]> wrote:

>>>>>>> I will think about this, as right now no idea how to write test
>>>>>> cases for this.
>>>>>>
>>>>>
>>>>>>>> I have tested this patch with ldap and ldap + ssl/tls. With the
>>>>>>>> TLS, I have used the default config of ldap3 without certificates.
>>>>>>>>

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 2 Apr 2020 16:55:45 +0530

Hi Khushboo

Following are the initial review comments (GUI):

*Desktop Mode: *

   - KeyError: '_auth_source_manager_obj' in desktop mode. (*Note* error
   occurs when the patch has applied and server mode is False.)

*Server Mode:*

AUTHENTICATION_SOURCES = ['internal']

   - Try to add a new user with the same email address, it throws a
   unique key constraint error. Validation was there previously before saving
   it.

AUTHENTICATION_SOURCES = ['internal', 'ldap']

   - Try to add a new user with the same email address, it throws
   unique key constraint error which should not it may possible that the user
   has the same email address for internal and ldap.

AUTHENTICATION_SOURCES = ['ldap']

   - If ipAddress or Port is not set in the configuration file then browser
   showing the following data, it should be shown proper error message on the
   login page
      - {"success":0,"errormsg":"Port could not be cast to integer value as
      '<port>'","info":"","result":null,"data":null}
   - If IP address and port is provided but it is wrong, it shows the
   following error, can we make a generic error message? Also clicking on the
   Close button on that error message is not working.
   - IP address and port of LDAP server are correct, give wrong user name
   and password, it shows error "Error binding to the LDAP Server: None".
   Please correct the appropriate error message.
   - All the configuration parameter is correct and tries to log in on LDAP
   server using username (*not email address*) and password got following
   error:

current_user.email.split('@')[0] if config.SERVER_MODE is True
AttributeError: 'NoneType' object has no attribute 'split'.

Not able to test due to the above error. Please fix and resend the patch.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Khushboo Vashi <[email-masked]>
Date: Thu, 2 Apr 2020 19:00:41 +0530

Hi Akshay,

> If the source is internal, it will not allow but with ldap, we can add the
user with the same email id.

>    - If ipAddress or Port is not set in the configuration file then
>    browser showing the following data, it should be shown proper error message
>    on the login page
>       - {"success":0,"errormsg":"Port could not be cast to integer value
>       as '<port>'","info":"","result":null,"data":null}
>
> Done

> I will look into the close button issue as it is an existing issue.

>    -

>
>    - All the configuration parameter is correct and tries to log in on
>    LDAP server using username (*not email address*) and password got following
>    error:
>

Thanks,
Khushboo

Thanks,
Khushboo

>>> Please find the attached updated patch which includes the review
>>> comments given in the review meeting:
>>>
>>>>>>>>> There are many settings for the LDAP, and in the future we will
>>>>>>>> add other external sources also, so I thought it would be better if we have
>>>>>>> Sure, but our config file is small compared to many. Splitting
>>>>>>> things out is more confusing for users. If they want to do that themselves
>>>>>>> of course, they can add a config_local.py file which includes other files
>>>>>>> as needed.
>>>>>>>
>>>>>> Fixed.
>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>> - I think all config options should be prefixed with LDAP_ as we
>>>>>>>>> may have things like CERT_FILE for other purposes too.
>>>>>>>>>
>>>>>>>>> Sure.
>>>>>>>>
>>>>>>> Done.
>>>>>>
>>>>>>>>>> Note: For the document update I will create the task and assign
>>>>>>>>>> to Nidhi for the same.
>>>>>>>>>>
>>>>>>>>>> Thanks,
>>>>>>>>>> Khushboo
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> --
>>>>>>>>> Dave Page

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 3 Apr 2020 13:49:55 +0530

Hi Khushboo

Some more review comments:

   - Fix one small PEP8 issue.
   - If ipAddress or Port is not set in the configuration file then browser
   showing the following data, it should be shown proper error message on the
   login page
      - {"success":0,"errormsg":"Port could not be cast to integer value as
      '<port>'","info":"","result":null,"data":null}
   - Disable the Username field in the User Management dialog if the
   authentication source is set to internal.
   - API Test cases are failing if LDAP related settings are not
   provided in the test_config.json file. If the configuration is not provided
   then LDAP tests should be skipped.

@Dave, I have tested and done the code review. Can you please do it once as
well, whenever Khushboo will fix and send the updated patch?

On Thu, Apr 2, 2020 at 7:00 PM Khushboo Vashi <
[email-masked]> wrote:

>> If the source is internal, it will not allow but with ldap, we can add
> the user with the same email id.
>
>>    - IP address and port of LDAP server are correct, give wrong user
>>    name and password, it shows error "Error binding to the LDAP Server: None".
>>>>>>>>>> - Please move the configuration into config.py. Users should
>>>>>>>>>> never have to modify a distributed file (it messes up packaging). I don't
>>>>>>>>>> see any reason to use a different file just for auth config.
>>>>>>>>>>
>>>>>>>>>>> To test the patch, config_auth.py needs to be configured for
>>>>>>>>>>> LDAP configurations. The config settings are explained in this file in
>>>>>>>>>>> detail. After configuring the parameters, start the pgadmin server in
>>>>>>>>>>> Server mode and connect with LDAP server with the valid user via login page.
>>>>>>>>>>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Khushboo Vashi <[email-masked]>
Date: Fri, 3 Apr 2020 14:37:02 +0530

Hi,

> @Dave, I have tested and done the code review. Can you please do it once
> as well, whenever Khushboo will fix and send the updated patch?
>
> Thanks,
Khushboo

>> On Thu, Apr 2, 2020 at 4:55 PM Akshay Joshi <
>> [email-masked]> wrote:
>>
>>> Hi Khushboo
>>>
>>>    - KeyError: '_auth_source_manager_obj' in desktop mode. (*Note*
>>>    error occurs when the patch has applied and server mode is False.)
>>>
>>> Fixed.
>>
>>> *Server Mode:*
>>>
>>>       - {"success":0,"errormsg":"Port could not be cast to integer
>>>       value as '<port>'","info":"","result":null,"data":null}
>>>
>>> Done
>>
>>>
>>>>>>>>>>>> Please find the attached patch to support LDAP Authentication
>>>>>>>>>>>> in Server mode.

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 6 Apr 2020 15:58:13 +0530

Thanks, patch applied.

On Fri, Apr 3, 2020 at 2:37 PM Khushboo Vashi <
[email-masked]> wrote:

>>>>>>>>>> It should be fairly straightforward to write tests for some of
>>>>>>>>>> the functions in the auth classes. For testing the actual LDAP stuff, we
>>>>>>>>>>>>> I have tested this patch with ldap and ldap + ssl/tls. With
>>>>>>>>>>>>> the TLS, I have used the default config of ldap3 without certificates.
>>>>>>>>>>>>>
>>>>>>>>>>>>> Note: For the document update I will create the task and
>>>>>>>>>>>>> assign to Nidhi for the same.
>>>>>>>>>>>>>
>>>>>>>>>>>>> Thanks,
>>>>>>>>>>>>> Khushboo
>>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> --
>>>>>>>>>>>> Dave Page

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*