Subject: [pgAdmin4][Patch] - RM 1402 - Macro support like pgAdmin3

From: Khushboo Vashi <[email-masked]>
Date: Mon, 21 Sep 2020 14:19:30 +0530

Hi,

Please find the attached patch for RM 1402 - Macro support like pgAdmin3.

Thanks,
Khushboo

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 23 Sep 2020 17:42:03 +0530

Hi Khushboo

Following are the GUI review comments:

   - If we provide anyone value either Name or SQL it throws Alertify error
   message with 'name' or 'SQL'. The error message should be correct.

   - We should not enable the 'Save' button if the value of Name or SQL is
   not entered by the user. Either both values should be there or both should
   be blank.
   - Click on anywhere inside the empty cell where the clear row icon is
   not visible, it pops up the message to clear the row which is already
   empty.

   - Save any macro and then open the "Manage Macros..." dialog again click
   on the SQL control for the existing macro, cursor is not at the appropriate
   place.

   - Macros are not working for multiple users. Create some macro from
   User1 and then log in using User2, macros created by User1 are visible to
   User2 and when I try to update it is not updating.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Khushboo Vashi <[email-masked]>
Date: Mon, 28 Sep 2020 14:17:55 +0530

Hi,

Please find the attached updated patch.

Thanks,
Khushboo

On Wed, Sep 23, 2020 at 5:42 PM Akshay Joshi <[email-masked]>
wrote:

>    - If we provide anyone value either Name or SQL it throws Alertify
>    error message with 'name' or 'SQL'. The error message should be correct.
>
>
Fixed.

>
>    - We should not enable the 'Save' button if the value of Name or SQL
>    is not entered by the user. Either both values should be there or both
>    should be blank.
>
> Fixed.

>    not visible, it pops up the message to clear the row which is already
Fixed.

>
>    - Save any macro and then open the "Manage Macros..." dialog again
>    click on the SQL control for the existing macro, cursor is not at the
>    appropriate place.
>
>
Fixed.

> Fixed.

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 28 Sep 2020 17:56:45 +0530

Thanks, patch applied.

On Mon, Sep 28, 2020 at 2:18 PM Khushboo Vashi <
[email-masked]> wrote:

> On Wed, Sep 23, 2020 at 5:42 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Khushboo
>>