Subject: [pgAdmin4][Patch]: RM 3927 Unable to debug the procedure inside package

From: Akshay Joshi <[email-masked]>
Date: Mon, 28 Jan 2019 18:02:53 +0530

Hi Hackers,

Attached is the patch to fix RM 3927 "Unable to debug the procedure inside
package". Problem with the existing code is we assume that "PLDBGBREAK"
will be always found in the first element of the notification list.

In this patch we loop through the list and found the string. Apart from
that patch contains small fix to cancel the transaction of Query Tool when
panel is closed.

Please review it.

-- 
*Akshay Joshi*

*Sr. Software Architect *

*Phone: +91 20-3058-9517Mobile: +91 976-788-8246*

---

From: Dave Page <[email-masked]>
Date: Tue, 29 Jan 2019 11:18:42 +0000

Khushboo, can you review this please? If you're happy with it, Akshay
can commit.

Thanks.

On Mon, Jan 28, 2019 at 12:33 PM Akshay Joshi
<[email-masked]> wrote:
>
> Hi Hackers,
>
> Attached is the patch to fix RM 3927 "Unable to debug the procedure inside package". Problem with the existing code is we assume that "PLDBGBREAK" will be always found in the first element of the notification list.
>
> In this patch we loop through the list and found the string. Apart from that patch contains small fix to cancel the transaction of Query Tool when panel is closed.
>
> Please review it.
>
> --
> Akshay Joshi
> Sr. Software Architect
>
>
> Phone: +91 20-3058-9517
> Mobile: +91 976-788-8246

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Khushboo Vashi <[email-masked]>
Date: Wed, 30 Jan 2019 10:17:38 +0530

Hi Akshay,

The issue has been fixed with this patch but I feel we need code
refactoring of the existing code especially the loop in which we find the
required string.
What's your thought?

Also, please remove the datagrid/__init__.py file from the patch which I
assume you have sent by mistake.

Thanks,
Khushboo

On Tue, Jan 29, 2019 at 4:49 PM Dave Page <[email-masked]> wrote:

> > Attached is the patch to fix RM 3927 "Unable to debug the procedure
> inside package". Problem with the existing code is we assume that
> "PLDBGBREAK" will be always found in the first element of the notification
> list.
> >

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 30 Jan 2019 13:05:06 +0530

Hi Khushboo

> refactoring of the existing code especially the loop in which we find the

    Attached is the updated patch. Please review it.

> assume you have sent by mistake.

    No that file contains fix to cancel the transaction of Query Tool. By
mistake that line is commented out.

-- 
*Akshay Joshi*

---

From: Khushboo Vashi <[email-masked]>
Date: Wed, 30 Jan 2019 14:19:14 +0530

The patch looks good to me.

On Wed, Jan 30, 2019 at 1:05 PM Akshay Joshi <[email-masked]>
wrote:

>>> > In this patch we loop through the list and found the string. Apart
>>> from that patch contains small fix to cancel the transaction of Query Tool
>>> when panel is closed.
>>> >
>>> > Please review it.
>>> >
>>> > --
>>> > Akshay Joshi
>>> > Sr. Software Architect
>>> >
>>> >
>>> > Phone: +91 20-3058-9517
>>> > Mobile: +91 976-788-8246
>>>
>>>
>>>
>>> --
>>> Dave Page