Subject: [PGAGENT] Upgrade pgAgent from unpackaged version

From: Ashesh Vashi <[email-masked]>
Date: Wed, 13 Jun 2018 09:41:02 +0530

Hi Dave,

As per my conversation with Rushabh, we need to rename the
pgagent--unpackaged--3.4.sql to pgagent--unpackaged--4.0.sql as it the
current version has changed. We also need to update the schema version
function for the unpackaged extension.

Please find the attached patch for the same.

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>

---

From: Dave Page <[email-masked]>
Date: Wed, 13 Jun 2018 13:40:34 +0100

Thanks, applied.

On Wed, Jun 13, 2018 at 5:11 AM, Ashesh Vashi <[email-masked]
> wrote:

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Rushabh Lathia <[email-masked]>
Date: Thu, 14 Jun 2018 10:19:27 +0530

Thanks Ashesh and Dave.

I verified the changes and it looks good to me.  I found that newly
added unpackaged file still have old file header comment.  Which
require change with new file name.

PFA patch to fix the same.

Thanks,

On Wed, Jun 13, 2018 at 6:10 PM, Dave Page <[email-masked]> wrote:

> Thanks, applied.
>
> On Wed, Jun 13, 2018 at 5:11 AM, Ashesh Vashi <
> [email-masked]> wrote:
>
>> Hi Dave,
>>

-- 
--

Rushabh Lathia
Database Architect
EnterpriseDB Corporation
The Enterprise Postgres Company

Phone: +91-20-30589494

Website: http://www.enterprisedb.com
EnterpriseDB Blog: http://blogs.enterprisedb.com/
Follow us on Twitter: http://www.twitter.com/enterprisedb
diff --git a/sql/pgagent--unpackaged--4.0.sql b/sql/pgagent--unpackaged--4.0.sql
index 302dde4..b0e2cce 100644
--- a/sql/pgagent--unpackaged--4.0.sql
+++ b/sql/pgagent--unpackaged--4.0.sql
@@ -4,7 +4,7 @@
 // Copyright (C) 2002 - 2018 The pgAdmin Development Team
 // This software is released under the PostgreSQL Licence
 //
-// pgagent--unpackaged--3.4.sql - Convert pgAgent existing tables and functions to an extension
+// pgagent--unpackaged--4.0.sql - Convert pgAgent existing tables and functions to an extension
 //
 */

---

From: Dave Page <[email-masked]>
Date: Thu, 14 Jun 2018 09:27:15 +0100

Thanks Rushabh - patch applied!