Subject: Patch: Added select2cell editor for backgrid [pgAdmin4]

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 31 Mar 2016 12:27:18 +0530

Hi,

We have added Select2Cell Editor for backgrid, eariler as it was not
present & causing issue in rendering in subnode control.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Ashesh Vashi <[email-masked]>
Date: Fri, 1 Apr 2016 15:08:30 +0530

> present & causing issue in rendering in subnode control.
Looks good to me, but - have some feedback.
1. Can you please mention - why do we need 'openOnEnter: false' in select2
options?
2. There is a difference between UI, when rendered from the editor, and
from the Select2Cell. (I can see padding, when the Cell is rendered, but -
not when editor is rendered.)

Can you please fix this two?

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com/>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>

---

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 4 Apr 2016 13:09:02 +0530

Hi,

PFA updated patch.

Regards,
Murtuza

---

From: Ashesh Vashi <[email-masked]>
Date: Mon, 4 Apr 2016 15:37:09 +0530

Thanks - committed with small changes.

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

On Mon, Apr 4, 2016 at 1:09 PM, Murtuza Zabuawala <
[email-masked]> wrote:

> On Fri, Apr 1, 2016 at 3:08 PM, Ashesh Vashi <
> [email-masked]> wrote:
>
>> 1. Can you please mention - why do we need 'openOnEnter: false' in
>> select2 options?

---

From: Dave Page <[email-masked]>
Date: Tue, 5 Apr 2016 16:51:06 +0100

I've reverted the change to overrides.css that this patch made as it was
that that was causing the padding issue on backgrid that we noted this
morning when looking at the debugger.

+}
+
+.select2-cell .select2-container > .backgrid th, .backgrid td
+{
+    padding: 0px;

Please fix in a less blanket way.

On Mon, Apr 4, 2016 at 11:07 AM, Ashesh Vashi <[email-masked]

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company