Subject: [pgAdmin4][RM3865] Difficult to resize Query Tool

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 30 Jan 2019 12:32:30 +0530

Hi Hackers,

With my pull request for changes in wcDocker merged (
https://github.com/EnterpriseDB/wcDocker/commit/9cf81f03bb350b76b77a264f1db5d55391d5e424),
we are now able to increase the mouse hover area of the frame splitters
without increasing visible splitter lines width.
Attached is the patch for changes required in pgAdmin accordingly. I have
kept the total hover width as $splitter-hover-width:5px, which can be
changed.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB Software Solutions | Pune
"Don't Complain about Heat, Plant a tree"

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 30 Jan 2019 14:27:09 +0530

Thanks patch applied.

-- 
*Akshay Joshi*

*Sr. Software Architect *

*Phone: +91 20-3058-9517Mobile: +91 976-788-8246*

---

From: Ashesh Vashi <[email-masked]>
Date: Wed, 30 Jan 2019 14:31:58 +0530

Hi Dave,

I was having conversation with Aditya about "What should be the mouse hover
(resize selection) area of the splitters?".
I asked him to set it to 5px.

But - he has different opinion, was in favor to keep it around '11px'.

Please advise.

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 30 Jan 2019 14:47:23 +0530

Hi Dave

On Wed, Jan 30, 2019 at 2:32 PM Ashesh Vashi <[email-masked]>
wrote:

> Hi Dave,
>
> I was having conversation with Aditya about "What should be the mouse
> hover (resize selection) area of the splitters?".

    I have committed with 7px which looks good, but it would be good to
have your opinion on this. You will have to run "Yarn Install" to test
this.

-- 
*Akshay Joshi*

---

From: Dave Page <[email-masked]>
Date: Thu, 31 Jan 2019 13:36:30 +0000

On Wed, Jan 30, 2019 at 10:17 AM Akshay Joshi <[email-masked]>
wrote:

> Hi Dave
>
> On Wed, Jan 30, 2019 at 2:32 PM Ashesh Vashi <
> [email-masked]> wrote:
>
>> Hi Dave,
>>

Seems fine to me. Thanks.

>>> Attached is the patch for changes required in pgAdmin accordingly. I
>>> have kept the total hover width as $splitter-hover-width:5px, which can be
>>> changed.
>>>
>>> Kindly review.
>>>
>>> --
>>> Thanks and Regards,
>>> Aditya Toshniwal

-- 
Dave Page
VP, Chief Architect, Tools & Installers
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake