Subject: [pgAdmin4][patch]: Unable to create extension "postgis_topology" and "postgis_tiger_geocoder" installed through stack builder

From: Surinder Kumar <[email-masked]>
Date: Fri, 6 May 2016 16:32:22 +0530

Hi,

PFA patch to fix the issue:
Unable to create extension "postgis_topology" and "postgis_tiger_geocoder",
due to wrong schema name in generated SQL query.

*For example*:

It generates following query for '*postgis_toplology*' extension:
CREATE EXTENSION *postgis_topology* SCHEMA *topology*;

which is wrong. the correct query should be:
CREATE EXTENSION *postgis_topology*;

where it fetches '*topology*' schema from table *pg_available_extensions*
and
then sets schema when extension name is selected, but it should not set
schema on name change.
It is now fixed in this patch.
Thanks Fahar for reporting.

Please review and let me know for comments.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Ashesh Vashi <[email-masked]>
Date: Sat, 14 May 2016 15:44:19 +0530

Thanks - committed!

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>

On Fri, May 6, 2016 at 4:32 PM, Surinder Kumar <
[email-masked]> wrote:

> Unable to create extension "postgis_topology" and
> "postgis_tiger_geocoder", due to wrong schema name in generated SQL query.
>
> *For example*:
>