Subject: Dialogues not closing

From: Dave Page <[email-masked]>
Date: Thu, 14 Apr 2016 21:53:39 +0100

Hey Ashesh,

We have an issue with dialogues not closing on Save button presses.
One of the team told me yesterday or the day before that it's a
general issue, not one specific to the patch I was reviewing at the
time, which I've been finding seems to be the case.

Any idea what this issue is?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Ashesh Vashi <[email-masked]>
Date: Fri, 15 Apr 2016 11:02:39 +0530

> Any idea what this issue is?
Sure - I will look into it.

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com/>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>

---

From: Dave Page <[email-masked]>
Date: Fri, 15 Apr 2016 08:50:56 +0100

On Fri, Apr 15, 2016 at 6:32 AM, Ashesh Vashi <[email-masked]
> wrote:

> Sure - I will look into it.

Thanks - please make it a priority; I'm at PG Conf NYC next week and expect
to be doing lots of demos.

---

From: Ashesh Vashi <[email-masked]>
Date: Fri, 15 Apr 2016 13:36:13 +0530

Hi Dave,

On Fri, Apr 15, 2016 at 1:20 PM, Dave Page <[email-masked]> wrote:

>
>
> On Fri, Apr 15, 2016 at 6:32 AM, Ashesh Vashi <
> [email-masked]> wrote:
>
> Thanks - please make it a priority; I'm at PG Conf NYC next week and
> expect to be doing lots of demos.
>
Please find the patch for the same.

This also includes some of the cleanup required to solve some of the memory
leak issues.

I was not able to reproduce the issue at my end, but - I've idea of when it
could fail to close the panel, which I have resolved in this patch.
Can you please test it?

--

Thanks & Regards,

Ashesh Vashi

---

From: Ashesh Vashi <[email-masked]>
Date: Fri, 15 Apr 2016 16:18:15 +0530

Hi Dave,

I was able to reproduce the issue with the help of Murtuza.
I missed one corner case - it was not able to close the dialog, when the
parent/collection has not yet been loaded.

Please find the updated patch.
This patch only includes the dialog issue.
Please let me know - if you still see the issue.

I've committed the patch about the objects (model/collection/views) release.

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

On Fri, Apr 15, 2016 at 1:36 PM, Ashesh Vashi <[email-masked]

> This also includes some of the cleanup required to solve some of the
> memory leak issues.
>
> I was not able to reproduce the issue at my end, but - I've idea of when
> it could fail to close the panel, which I have resolved in this patch.
> Can you please test it?
>
> --
>
> Thanks & Regards,
>
> Ashesh Vashi

---

From: Ashesh Vashi <[email-masked]>
Date: Fri, 15 Apr 2016 16:18:50 +0530

Oops.. clicked before attaching...

--

Thanks & Regards,

Ashesh Vashi

On Fri, Apr 15, 2016 at 4:18 PM, Ashesh Vashi <[email-masked]

> On Fri, Apr 15, 2016 at 1:36 PM, Ashesh Vashi <

---

From: Dave Page <[email-masked]>
Date: Fri, 15 Apr 2016 14:02:34 +0100

That seems to have got it - thanks!

On Fri, Apr 15, 2016 at 11:48 AM, Ashesh Vashi <
[email-masked]> wrote:

> On Fri, Apr 15, 2016 at 4:18 PM, Ashesh Vashi <