Subject: [Patch] Fix libssh2 build error on vs2010

From: Nikolai Zhubr <[email-masked]>
Date: Thu, 07 Jan 2016 15:49:17 +0300

Hello all,

Please consider the attached trivial patch to fix build errors with VS2010.
Supposedly it would not hurt anyway.

Thank you,
Nikolai

--- pgadmin/libssh2/hostkey.c.orig	2016-01-04 16:05:37.000000000 +0300
+++ pgadmin/libssh2/hostkey.c	2016-01-07 15:34:02.646575436 +0300
@@ -277,8 +277,8 @@
     libssh2_dsa_ctx *dsactx;
     const unsigned char *p, *q, *g, *y, *s;
     unsigned long p_len, q_len, g_len, y_len, len;
+    int ret;
     (void) hostkey_data_len;
-	int ret;
 
     if (*abstract) {
         hostkey_method_ssh_dss_dtor(session, abstract);

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Ashesh Vashi <[email-masked]>
Date: Thu, 7 Jan 2016 18:27:54 +0530

Done.

Thanks

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>