Subject: [pgAdmin][RM5154] [Accessibility] : Alertify

From: Pradip Parkale <[email-masked]>
Date: Wed, 19 Feb 2020 16:58:35 +0530

Hi Hackers,

Attached is a patch for accessibility issue related Alertifyjs.

   1. Added hidden label to satisfy accessibility.
   2. Added label with sr-only class.
   3. Added tabindex to move the mouse control to the maximize button using
   the tab key.

Please note that this patch also includes the fix for the
RM-5143 Accessibility issue to maximize the panel for backup and restore
windows and all other places.
-- 
Thanks & Regards,
Pradip Parkale
QMG, EnterpriseDB Corporation

---

From: Ashesh Vashi <[email-masked]>
Date: Wed, 19 Feb 2020 17:02:02 +0530

Forgot to attach the patch?

On Wed, 19 Feb 2020 at 16:58, Pradip Parkale <
[email-masked]> wrote:

>    3. Added tabindex to move the mouse control to the maximize button
>    using the tab key.
>
>
-- 

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>

---

From: Pradip Parkale <[email-masked]>
Date: Wed, 19 Feb 2020 17:04:13 +0530

Please find the attached patch.

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 21 Feb 2020 11:19:37 +0530

Hi Aditya

Can you please review this patch.

On Wed, Feb 19, 2020 at 5:04 PM Pradip Parkale <
[email-masked]> wrote:

> On Wed, Feb 19, 2020 at 5:02 PM Ashesh Vashi <
> [email-masked]> wrote:
>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 24 Feb 2020 14:33:36 +0530

Hi Pradip,

-
 commonUtils.findAndSetFocus($(alertifyDialog.elements.body).find('.tab-content
div.active'));
+
 $(alertifyDialog.elements.dialog).find('[tabindex]:not([tabindex="-1"]').first().focus();

Use the same common function with
commonUtils.findAndSetFocus(alertifyDialog.elements.dialog)). It will
handle the focus.
Also, make the required changes mentioned on the pull request -
https://github.com/EnterpriseDB/AlertifyJS/pull/1

-- 
Thanks and Regards,
Aditya Toshniwal
pgAdmin Hacker | Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Pradip Parkale <[email-masked]>
Date: Tue, 25 Feb 2020 15:32:03 +0530

Hi Akshay/Aditya,

Please find the updated patch. I have accommodated all the changes.

> commonUtils.findAndSetFocus(alertifyDialog.elements.dialog)). It will
Fixed.

> https://github.com/EnterpriseDB/AlertifyJS/pull/1
Fixed.

>
>
> On Fri, Feb 21, 2020 at 11:19 AM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Aditya
>>

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 25 Feb 2020 18:26:00 +0530

Thanks, patch applied.

On Tue, Feb 25, 2020 at 3:32 PM Pradip Parkale <
[email-masked]> wrote:

>>>>>>    3. Added tabindex to move the mouse control to the maximize
>>>>>>    button using the tab key.
>>>>>>
>>>>>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Pradip Parkale <[email-masked]>
Date: Thu, 5 Mar 2020 18:02:05 +0530

Hi Hackers,
Please find the updated patch for RM5143.

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 6 Mar 2020 18:48:38 +0530

Thanks, patch applied.

On Thu, Mar 5, 2020 at 6:02 PM Pradip Parkale <
[email-masked]> wrote:

> On Tue, Feb 25, 2020 at 6:26 PM Akshay Joshi <

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*