Subject: [pgAdmin4][Patch]: Fixed the TypeError into session.py

From: Khushboo Vashi <[email-masked]>
Date: Tue, 26 Apr 2016 16:03:59 +0530

Hi,

Fixed an issue related to Type ( TypeError: 'str' does not support the
buffer interface)
for python3 in the session.py.

Please find attachment for the same.

Thanks,
Khushboo
diff --git a/web/pgadmin/utils/session.py b/web/pgadmin/utils/session.py
index 6675e88..f4daefb 100644
--- a/web/pgadmin/utils/session.py
+++ b/web/pgadmin/utils/session.py
@@ -101,7 +101,7 @@ class SqliteSessionStorage(MutableMapping, SessionMixin):
         """
         with self._get_conn() as conn:
             for row in conn.execute(self._ite_sql):
-                yield loads(str(row[0]))
+                yield loads(dumps(row[0]))
 
     def __len__(self):
         """Returns the number of keys stored in this session.

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Ashesh Vashi <[email-masked]>
Date: Tue, 26 Apr 2016 16:16:55 +0530

Thanks - committed!

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>