Subject: Patch for TypeError: this.field is undefined error

From: Harshal Dhumal <[email-masked]>
Date: Tue, 12 Jan 2016 10:57:31 +0530

Hi,

Please find attached minor patch for TypeError: this.field is undefined
error in pgadmin.backform.js

-- 
*Harshal Dhumal*
*Software Engineer *

EenterpriseDB <http://www.enterprisedb.com>
diff --git a/web/pgadmin/static/js/backform.pgadmin.js b/web/pgadmin/static/js/backform.pgadmin.js
index a753f5d..6ef634c 100644
--- a/web/pgadmin/static/js/backform.pgadmin.js
+++ b/web/pgadmin/static/js/backform.pgadmin.js
@@ -858,7 +859,7 @@
       this.clearInvalid();
 
       this.$el.find('.subnode-body').each(function(ix, el) {
-        var error = self.keyPathAccessor(errorModel.toJSON(), this.field.get('name'));
+        var error = self.keyPathAccessor(errorModel.toJSON(), self.field.get('name'));
 
         if (_.isEmpty(error)) return;

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Ashesh Vashi <[email-masked]>
Date: Tue, 12 Jan 2016 11:19:16 +0530

Thanks - I will look into it.

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>