Subject: pgAdmin III commit: Resolved an issue related enable/disable menu items

From: Ashesh Vashi <[email-masked]>
Date: Tue, 22 Sep 2015 07:56:32 +0000

Resolved an issue related enable/disable menu items in Query Editor
specifically for Unity Desktop Environment.

wxWidgets was not able to identify the current focused control in some
cases, during certain event generation. And, that was resulting into
disabling the wrong menu items.
i.e.
Copy, Paste, Undo, Redo, Cut, Paste, Add/Manage favourite menu(s)

In order to resolve the issue, we will not consider the events
generated, but - no control gets focused, while enabling/disabling the
menus.

Branch
------
master

Details
-------
http://git.postgresql.org/gitweb?p=pgadmin3.git;a=commitdiff;h=cd9f615564334ed91d4760c971beae249cf9bd83

Modified Files
--------------
CHANGELOG                |    3 +++
pgadmin/frm/frmQuery.cpp |   59 +++++++++++++++++++++++++++-------------------
2 files changed, 38 insertions(+), 24 deletions(-)

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: "J.F. Oster" <[email-masked]>
Date: Wed, 23 Sep 2015 07:53:05 +0300

Hi Ashesh,

Favourite's issue is resolved, but looks like Edit - Cut/Copy/Paste
items are disabled all the time (seen on Ubuntu, Kubuntu).

Tuesday, September 22, 2015, 10:56:32 AM, you wrote:

AV> Resolved an issue related enable/disable menu items in Query Editor
AV> specifically for Unity Desktop Environment.

AV> wxWidgets was not able to identify the current focused control in some
AV> cases, during certain event generation. And, that was resulting into
AV> disabling the wrong menu items.
AV> i.e.
AV> Copy, Paste, Undo, Redo, Cut, Paste, Add/Manage favourite menu(s)

AV> In order to resolve the issue, we will not consider the events
AV> generated, but - no control gets focused, while enabling/disabling the
AV> menus.

AV> Branch
AV> ------
AV> master

AV> Details
AV> -------
AV> http://git.postgresql.org/gitweb?p=pgadmin3.git;a=commitdiff;h=cd9f615564334ed91d4760c971beae249cf9bd83

AV> Modified Files
AV> --------------
AV> CHANGELOG                |    3 +++
AV> pgadmin/frm/frmQuery.cpp |   59
AV> +++++++++++++++++++++++++++-------------------
AV> 2 files changed, 38 insertions(+), 24 deletions(-)

-- 
Best regards,
 J.F.

---

From: Ashesh Vashi <[email-masked]>
Date: Wed, 23 Sep 2015 10:27:18 +0530

> items are disabled all the time (seen on Ubuntu, Kubuntu).
I've tested the patch couple of times on Ubuntu, and OSX both before
committing the changes.

Do you have time to look into it?

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>

> AV>

---

From: Ashesh Vashi <[email-masked]>
Date: Wed, 23 Sep 2015 10:36:46 +0530

> Do you have time to look into it?
Got the reason.
Thanks for the report.

--

Thanks & Regards,

Ashesh Vashi

---

From: Ashesh Vashi <[email-masked]>
Date: Wed, 23 Sep 2015 10:41:48 +0530

>> Do you have time to look into it?
Thanks once again.
Please check now.

--

Thanks & Regards,

Ashesh Vashi