Subject: [pgadmin4][patch][GreenPlum] Display SQL for tables takes 15 minutes to execute

From: Joao De Almeida Pereira <[email-masked]>
Date: Mon, 11 Jun 2018 16:20:01 -0400

Hi Hackers,

Attached you can find the diff file that corrects RM 3415
<https://redmine.postgresql.org/issues/3415>
​
Thanks
Joao

---

From: Ashesh Vashi <[email-masked]>
Date: Tue, 12 Jun 2018 09:57:14 +0530

Hi Joao,

> <https://redmine.postgresql.org/issues/3415>
If I understand correctly, you're disabling the privileges for GPDB.
Is that correct?

-- Thanks, Ashesh

​

---

From: Robert Eckhardt <[email-masked]>
Date: Tue, 12 Jun 2018 00:32:01 -0400

> If I understand correctly, you're disabling the privileges for GPDB.

It should be only for Greenplum. There was a performance optimization in
Postgres 9.2 that make the current query in Postgres performant.

Rob

---

From: Ashesh Vashi <[email-masked]>
Date: Tue, 12 Jun 2018 10:04:56 +0530

On Tue, Jun 12, 2018 at 10:02 AM, Robert Eckhardt <[email-masked]>
wrote:

> It should be only for Greenplum.
>
Yeah - I got that.

> There was a performance optimization in Postgres 9.2 that make the current
> query in Postgres performant.
>
Ok.

Changes looks good to me.

-- Thanks, Ashesh

---

From: Ashesh Vashi <[email-masked]>
Date: Tue, 12 Jun 2018 11:04:51 +0530

On Tue, Jun 12, 2018 at 10:04 AM, Ashesh Vashi <
[email-masked]> wrote:

>> On Tue, Jun 12, 2018, 12:27 AM Ashesh Vashi <
>> [email-masked]> wrote:
>>
>>> Hi Joao,
>>>
>> There was a performance optimization in Postgres 9.2 that make the
>> current query in Postgres performant.
>>
> Ok.
>
Committed!

-- Thanks, Ashesh

---

From: Dave Page <[email-masked]>
Date: Wed, 13 Jun 2018 09:24:27 +0100

On Tue, Jun 12, 2018 at 6:34 AM, Ashesh Vashi <[email-masked]

>> Changes looks good to me.

Should this have included an updated to the release notes?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company