Subject: [pgAdmin][SonarQube] : Remove duplicates string literals.

From: Pradip Parkale <[email-masked]>
Date: Thu, 3 Sep 2020 16:29:44 +0530

Hi Hackers,

Attached is a patch for removing duplicates string literals.
        /server_groups/servers/roles/__init__.py  - 8 places

-- 
Thanks & Regards,
Pradip Parkale
Software Engineer | EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 3 Sep 2020 18:24:21 +0530

Hi Pradip

Following are the review comments:

   - ROLE_NOT_FOUND already in wrapped in gettext() then no need to use
   like gone(_(ROLE_NOT_FOUND)). In fact, can we use

   self.not_found_error_msg()instead of new constant.

   - Same with ERROR_FETCHING_ROLE_INFORMATION it's already in gettext,
   also we can use this constant for string "

   Error retrieving roles from the database server"

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Pradip Parkale <[email-masked]>
Date: Thu, 3 Sep 2020 19:19:09 +0530

Hi Akshay,

Please find the updated patch.

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 7 Sep 2020 18:48:24 +0530

Thanks, patch applied.