Subject: [pgAdmin][RM7031]: Database definition wrong

From: Pradip Parkale <[email-masked]>
Date: Wed, 1 Dec 2021 16:22:44 +0530

Hi Hackers,

Please find the attached for #7031 Database definition wrong.

-- 
Thanks & Regards,
Pradip Parkale
Software Engineer | EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 1 Dec 2021 17:25:17 +0530

Thanks, the patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 1 Dec 2021 17:56:02 +0530

Hi Pradip,

You did not include the server_old table for query_history. Please also
remove the commented code:
+    # db.engine.execute("PRAGMA foreign_keys=ON")
+
+    # db.session.commit()
+
+    # db.engine.execute("PRAGMA foreign_keys=ON")
+

-- 
Thanks,
Aditya Toshniwal
pgAdmin Hacker | Software Architect | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Pradip Parkale <[email-masked]>
Date: Thu, 2 Dec 2021 15:09:29 +0530

Hi Akshay/Aditya,

Please find the updated patch.

On Wed, Dec 1, 2021 at 5:56 PM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Pradip,
>
> You did not include the server_old table for query_history.
>
Fixed.

> Please also remove the commented code:
Fixed.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 2 Dec 2021 16:29:30 +0530

On Thu, Dec 2, 2021 at 3:09 PM Pradip Parkale <
[email-masked]> wrote:

>> On Wed, Dec 1, 2021 at 5:25 PM Akshay Joshi <
>> [email-masked]> wrote:
>>