Subject: [PgAdmin][RM4237]: User can not change value of Datetime picker control using keyboard (Accessibility).

From: Pradip Parkale <[email-masked]>
Date: Sat, 7 Mar 2020 18:59:46 +0530

Hi Hackers,

Attached is a patch to change the Datetime picker value using a keyboard.

-- 
Thanks & Regards,
Pradip Parkale
QMG, EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 9 Mar 2020 11:09:30 +0530

Hi Pradip

I have tested the patch. I am able to navigate the dates using the
keyboard, but not able to select the year/month and time. Can you please
work on it and send the patch again.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Pradip Parkale <[email-masked]>
Date: Tue, 10 Mar 2020 13:17:22 +0530

Hi Akshay,
I have already added the code to change the time. To select the time
picker, the user needs to press 'Alt+T' (Option+T for mac)  and then
Up/Down arrows to change the minutes and Alt + Up/Down to change the hours.

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 10 Mar 2020 13:23:50 +0530

Thanks, patch applied.

On Tue, Mar 10, 2020 at 1:17 PM Pradip Parkale <
[email-masked]> wrote:

> On Mon, Mar 9, 2020 at 11:09 AM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Pradip
>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Khushboo Vashi <[email-masked]>
Date: Tue, 10 Mar 2020 14:20:29 +0530

Hi Pradip,

Looks like you have repeated below code in if and else both the conditions.

let $el = this.$el.find('.datetimepicker-input');
let currdate = $el.data('datetimepicker').date().clone();

We can optimize this code by taking these both lines above if condition.

Thanks,
Khushboo