Subject: [pgAdmin4][Patch] - SonarQube Fixes

From: Khushboo Vashi <[email-masked]>
Date: Mon, 3 Aug 2020 13:36:09 +0530

Hi,

Please find the attached patch to fix the sonarqube code smells having the
rule "String literals should not be duplicated".

Thanks,
Khushboo

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 4 Aug 2020 12:10:17 +0530

Hi Khushboo

As per offline discussion, multiple developers declaring the constant for
the same string and error messages. To avoid that only one developer should
work on this task.
Suggestions:

   - We should have a common class for Constants (which are not module
   specific).
   - For module specific constants we should not declare them as Global
   variables if possible declare them as the Class variable.
   - For common error messages(if any) we can define functions in
   PGChildNodeView.

Please incorporate the changes send by Yogesh.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Khushboo Vashi <[email-masked]>
Date: Wed, 19 Aug 2020 14:01:01 +0530

Hi,

Please find the attached updated patch.

On Tue, Aug 4, 2020 at 12:10 PM Akshay Joshi <[email-masked]>
wrote:

> Made a constant.py file which contains the common Constants.

> Already implemented.

> Please incorporate the changes send by Yogesh.
I will send another patch for Yogesh's changes as needed more changes.

Thanks,
Khushboo

>> Please find the attached patch to fix the sonarqube code smells having
>> the rule "String literals should not be duplicated".
>>
>> Thanks,
>> Khushboo
>>
>
>
> --
> *Thanks & Regards*
> *Akshay Joshi*

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 19 Aug 2020 14:26:57 +0530

Thanks, patch applied.

On Wed, Aug 19, 2020 at 2:01 PM Khushboo Vashi <
[email-masked]> wrote:

> On Tue, Aug 4, 2020 at 12:10 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Khushboo
>>

---

From: Khushboo Vashi <[email-masked]>
Date: Thu, 3 Sep 2020 16:39:05 +0530

Hi,

Please find more fixes for the sonarqube code smells having the rule "String
literals should not be duplicated".

Thanks,
Khushboo

On Wed, Aug 19, 2020 at 2:27 PM Akshay Joshi <[email-masked]>
wrote:

>>> As per offline discussion, multiple developers declaring the constant
>>> for the same string and error messages. To avoid that only one developer
>>> should work on this task.
>>> Suggestions:
>>>

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 3 Sep 2020 18:56:32 +0530

Thanks, patch applied.

On Thu, Sep 3, 2020 at 4:39 PM Khushboo Vashi <
[email-masked]> wrote:

> On Wed, Aug 19, 2020 at 2:27 PM Akshay Joshi <
>>>>    - For module specific constants we should not declare them as
>>>>    Global variables if possible declare them as the Class variable.
>>>>
>>>>