Subject: [pgAdmin][RM6520]: pgAdmin4 v 5.3 text export error

From: Pradip Parkale <[email-masked]>
Date: Fri, 11 Jun 2021 19:17:18 +0530

Hi Hackers,

Please find the attached patch for #6520.Added check to typecast the
numeric data while downloading the data in CSV format.

-- 
Thanks & Regards,
Pradip Parkale
Software Engineer | EnterpriseDB Corporation

---

From: Aditya Toshniwal <[email-masked]>
Date: Fri, 11 Jun 2021 19:37:54 +0530

Hi Pradip,

Just did a go through to your patch.
The variable "data" which you've formed, will be computed for every row
even though columns won't change. You should move it up and pass it to gen
directly. This will save repeated computations.
Secondly, it should not be named as data. It can be like - numeric_cols or
numeric_keys.

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Pradip Parkale <[email-masked]>
Date: Mon, 14 Jun 2021 15:37:12 +0530

Hi Aditya and Akshay,

Please find the updated patch. I have changed the variable name "data" to
'numeric_cols'.