Subject: [pgAdmin][RM5241] : Tab key navigation is not working in Grant wizard.

From: Pradip Parkale <[email-masked]>
Date: Fri, 27 Mar 2020 09:47:31 +0530

Hi Hackers,

Attached is a patch for tab key navigation on grant_wizard.

This patch includes:

   1. Added code to make tab navigation working in grant_wizard.
   2. Added entry for .scss to change the shadow of  'ajs-close' button.

This patch also includes the code to allow the user to use the keyboard to
update the Backgrid cell DateTime picker control.

-- 
Thanks & Regards,
Pradip Parkale
QMG, EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 27 Mar 2020 13:17:35 +0530

Hi Pradip

Following things are not working, please fix and resend the patch:

Object selection (First) Page:

   - If there is no object in the backgrid to select then tab navigation
   not proceed after the headers.
   - Tab navigation not working for 'Select All' checkbox in the backgrid
   cell.

Privileges selection (Second) Page:

   - Tab navigation not working for the 'Delete' button in the
   backgrid cell.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Pradip Parkale <[email-masked]>
Date: Mon, 30 Mar 2020 17:24:55 +0530

Hi Akshay,

Please find the attached patch.

On Fri, Mar 27, 2020 at 1:17 PM Akshay Joshi <[email-masked]>
wrote:

> Fixed.

> Fixed.

> This logic was added even before my patch(1st Patch). User needs to press
the 'space' key to delete the privilege added.

>> This patch also includes the code to allow the user to use the keyboard
>> to update the Backgrid cell DateTime picker control.
>>
>>
>> --
>> Thanks & Regards,
>> Pradip Parkale

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 30 Mar 2020 17:45:23 +0530

Thanks, patch applied.

On Mon, Mar 30, 2020 at 5:25 PM Pradip Parkale <
[email-masked]> wrote:

> On Fri, Mar 27, 2020 at 1:17 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Pradip
>>
>>    - Tab navigation not working for 'Select All' checkbox in the
>>    backgrid cell.
>>
>> Fixed.
>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*