Subject: [pgAdmin][RM5843] [SQL] - Some 'options' values for function not shown in sql

From: Pradip Parkale <[email-masked]>
Date: Tue, 22 Sep 2020 18:41:20 +0530

Hi Hackers,

The 'Unsafe' parallel option was not visible in the SQL for function and
procedure. Attached is the patch to fix this issue.

-- 
Thanks & Regards,
Pradip Parkale
Software Engineer | EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 23 Sep 2020 12:14:46 +0530

Hi Pradip

RESQL tests are failing on EPAS 9.5, 9.6, and 10. Please fix and resend the
patch.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 23 Sep 2020 13:25:23 +0530

Thanks, patch applied. It's a small fix so I have fixed it.

On Wed, Sep 23, 2020 at 12:14 PM Akshay Joshi <[email-masked]>
wrote:

> Hi Pradip
>
> RESQL tests are failing on EPAS 9.5, 9.6, and 10. Please fix and resend
> the patch.
>

---

From: Pradip Parkale <[email-masked]>
Date: Wed, 23 Sep 2020 23:30:12 +0530

Hi Akshay,

Please find the small patch for the ' Parallel Unsafe' option is missing in
SQL. It was missing in first patch for PG96 and PG10.

On Wed, Sep 23, 2020 at 1:25 PM Akshay Joshi <[email-masked]>
wrote:

> On Wed, Sep 23, 2020 at 12:14 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Pradip
>>

---

From: Pradip Parkale <[email-masked]>
Date: Thu, 1 Oct 2020 14:25:31 +0530

Hi Akshay,

Please find the attached patch to allow the user to modify the option
settings of the procedure. This issue was only for PPAS 11 and PPAS 12.

On Wed, Sep 23, 2020 at 11:30 PM Pradip Parkale <
[email-masked]> wrote:

> Hi Akshay,
>
> Please find the small patch for the ' Parallel Unsafe' option is missing
> in SQL. It was missing in first patch for PG96 and PG10.
>
>
> On Wed, Sep 23, 2020 at 1:25 PM Akshay Joshi <
>>>> The 'Unsafe' parallel option was not visible in the SQL for function
>>>> and procedure. Attached is the patch to fix this issue.
>>>>
>>>> --
>>>> Thanks & Regards,
>>>> Pradip Parkale

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 5 Oct 2020 14:41:27 +0530

Thanks, patch applied.

---

From: Pradip Parkale <[email-masked]>
Date: Mon, 12 Oct 2020 11:59:46 +0530

Hi Akshay,

Please find the attached patch for below issues:
1) The volatility option is not reflecting. It stays volatile always when
creating the function - Fixed
2) Set "Returns as set" to true and enter estimated rows like 12. Now set
returns as set to false and save. It gives ERROR: ROWS is not applicable
when function does not return a set. Need to clear estimated rows when
returns as set is false. - Fixed
3) If estimated rows are added and support function is selected then SQL
looks ugly. - Fixed

On Mon, Oct 5, 2020 at 2:41 PM Akshay Joshi <[email-masked]>
wrote:

>>>>> RESQL tests are failing on EPAS 9.5, 9.6, and 10. Please fix and
>>>>> resend the patch.
>>>>>

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 12 Oct 2020 14:10:45 +0530

Thanks, patch applied.

On Mon, Oct 12, 2020 at 11:59 AM Pradip Parkale <
[email-masked]> wrote:

>>>> Please find the small patch for the ' Parallel Unsafe' option is
>>>> missing in SQL. It was missing in first patch for PG96 and PG10.
>>>>
>>>>