Subject: [pgAdmin][RM6448]: [search object] error displayed for non superuser because of right on pg_catalog.pg_subscription

From: Pradip Parkale <[email-masked]>
Date: Tue, 22 Jun 2021 12:38:05 +0530

Hi Hackers,

Please find the attached patch for # 6448. I have added a check to ignore
the subscription when the search type is 'All type' if the user doesn't
have access to subscription.

-- 
Thanks & Regards,
Pradip Parkale
Software Engineer | EnterpriseDB Corporation

---

From: Fred <[email-masked]>
Date: Tue, 22 Jun 2021 10:51:38 +0200

nice !
thanks

fred

---

From: Pradip Parkale <[email-masked]>
Date: Tue, 22 Jun 2021 16:17:03 +0530

Hi Hackers,
Please ignore my previous email and find the attached patch. I have fixed
some review comments given by Aditya.

On Tue, Jun 22, 2021 at 2:21 PM Fred <[email-masked]> wrote:

> nice !
> thanks
>
> fred
>
>
> Le 22 juin 2021 09:08:05 GMT+02:00, Pradip Parkale <
> [email-masked]> a écrit :
>>
>> Hi Hackers,
>>

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 23 Jun 2021 12:52:17 +0530

Thanks, the patch applied.

On Tue, Jun 22, 2021 at 4:17 PM Pradip Parkale <
[email-masked]> wrote:

>>> Please find the attached patch for # 6448. I have added a check to
>>> ignore the subscription when the search type is 'All type' if the user
>>> doesn't have access to subscription.
>>>
>>> --
>>> Thanks & Regards,
>>> Pradip Parkale

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Pradip Parkale <[email-masked]>
Date: Mon, 19 Jul 2021 13:49:03 +0530

Hi Akshay,
Please find the updated patch.I have added a more reliable solution to
solve this issue.

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 19 Jul 2021 14:11:52 +0530

On Mon, Jul 19, 2021 at 1:49 PM Pradip Parkale <
[email-masked]> wrote:

> On Wed, Jun 23, 2021 at 12:52 PM Akshay Joshi <
> [email-masked]> wrote:
>
>>> Please ignore my previous email and find the attached patch. I have
>>> fixed some review comments given by Aditya.
>>>