Subject: RM4939 - Running in the container as non-root user

From: Dave Page <[email-masked]>
Date: Tue, 3 Dec 2019 21:51:35 -0500

The attached patch fixes $SUBJECT. I'm a little concerned about upgrades
though, mostly when using mapped storage or session data. Fahar, can you
test such scenarios please?

Patch review is also needed please :-)

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 4 Dec 2019 14:46:28 +0530

Hi Dave

I have reviewed the code and tested the basic scenario. The code looks good
to me. I have verified that the user is pgadmin with user id 5050.

With your patch                                        Without applying
your patch

@Fahar please test upgrades mostly when using mapped storage or session
data.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Dave Page <[email-masked]>
Date: Wed, 4 Dec 2019 05:53:23 -0500

Thanks!

On Wed, Dec 4, 2019 at 4:16 AM Akshay Joshi <[email-masked]>
wrote:

> Hi Dave
>
> I have reviewed the code and tested the basic scenario. The code looks
> good to me. I have verified that the user is pgadmin with user id 5050.
>

---

From: Fahar Abbas <[email-masked]>
Date: Mon, 9 Dec 2019 10:09:59 +0500

Hi,

Verification has been completed, now you can commit this patch.

-- 
Fahar Abbas
QMG
EnterpriseDB Corporation
Phone Office: +92-51-835-8874
Phone Direct: +92-51-8466803
Mobile: +92-333-5409707
Skype ID: *live:fahar.abbas*
Website: www.enterprisedb.com

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 9 Dec 2019 11:10:48 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*