Subject: Connection to the server has been lost

From: Ralph Ryl <[email-masked]>
Date: Thu, 29 Sep 2016 07:42:51 +0200

Dear pgadmin4 Developers,
on trying to connect remote postgresql-server, the connection lost. I
think the problem is the timeout for the connection. PGAdminIII works
for the same server without problems.
Maybe you can make an option in settings for the timout.

kind regards,

Ralph

-- 
Achtung: Das Thünen-Institut hat die Domain gewechselt.
Bitte ändern Sie meine Mailadresse in Ihrem Adressbuch!

Ralph Ryl
Thünen-Institut für Waldökosysteme / Thünen Institute of Forest Ecosystems
A.-Möller-Str. 1, Haus 41/42
D-16225 Eberswalde (Germany)

Tel:  +49 3334 3820-347
Fax:  +49 3334 3820-354
Mail: [email-masked]
Web:  www.thuenen.de 

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Fahar Abbas <[email-masked]>
Date: Mon, 3 Oct 2016 09:47:58 +0500

Hi Ralph,

This issue is not reproducible with remote server.

Can you please share the exact steps and *pgAdmin4.log* file location under
/home/fahar  for Linux and in Windows %AppData% with the team so they can
investigate the actual problem?

Regards,

-- 
Syed Fahar Abbas
Quality Management Group

EnterpriseDB Corporation
Phone Office: +92-51-835-8874
Phone Direct: +92-51-8466803
Mobile: +92-333-5409707
Skype ID: syed.fahar.abbas
Website: www.enterprisedb.com

---

From: Fahar Abbas <[email-masked]>
Date: Tue, 4 Oct 2016 12:30:49 +0500

Please also remember to add pgAdmin-hackers email list for every email in
that case, Development team can respond quickly.

Dave/Ashesh,

Please find below the output shared by Ralph.

Kind Regards,

On Tue, Oct 4, 2016 at 12:24 PM, Ralph Ryl <[email-masked]> wrote:

> Hi Fahar,
>
> here are the steps I do:
>
> - System: Ubuntu 14.04
>
> - I create an new server in a servergroup wich is not local
>
> - I enter correct logindata
>
> - if i directly try to connect an error with "bytea_output" appear
>
> - if i save the connection without directly connect it save the connection
>
> - if i doubleclick on the new connection pgadmin ask for the password(no
> matter if i save it) and show an message like "Connection to the server has
> been lost."
>
>
> here the last 50 lines from the logfile:
>
> 2016-10-04 09:20:37,847: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:20:37] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:20:42,858: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:20:42] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:20:47,869: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:20:47] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:20:52,879: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:20:52] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:20:57,891: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:20:57] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:21:02,902: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:02] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:21:07,912: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:07] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:21:12,924: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:12] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:21:16,626: INFO    pgadmin:    Connection Request for server#4
>
> 2016-10-04 09:21:16,629: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:16] "POST /browser/server/connect/2/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:21:17,935: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:17] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:21:18,188: INFO    pgadmin:    Connection Request for server#4
>
> 2016-10-04 09:21:18,211: SQL    pgadmin:    Execute (scalar) for server #4 - DB:postgres (Query-id: 8568684):
>
> SET DateStyle=ISO;
>
> SET client_min_messages=notice;
>
> SET bytea_output=escape;
>
> SET client_encoding='UNICODE';
>
> 2016-10-04 09:21:18,214: ERROR    pgadmin:    Failed to execute query (execute_scalar) for the server #4 - DB:postgres (Query-id: 8568684):
>
> Error Message:FEHLER:  unbekannter Konfigurationsparameter »bytea_output«
>
> 2016-10-04 09:21:22,946: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:22] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:21:27,959: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:27] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:21:31,139: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:31] "POST /misc/ping HTTP/1.1" 200 -
>
> 2016-10-04 09:21:32,973: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:32] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:21:37,986: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:37] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:21:43,001: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:43] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:21:48,022: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:48] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:21:53,034: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:53] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:21:58,046: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:21:58] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:22:03,058: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:22:03] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:22:08,068: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:22:08] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:22:13,080: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:22:13] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:22:18,092: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:22:18] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:22:23,105: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:22:23] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:22:28,116: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:22:28] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:22:33,130: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:22:33] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:22:38,142: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:22:38] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:22:43,154: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:22:43] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:22:48,165: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:22:48] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:22:53,176: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:22:53] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:22:58,186: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:22:58] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:23:03,196: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:23:03] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:23:08,210: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:23:08] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:23:13,226: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:23:13] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:23:18,236: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:23:18] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:23:23,247: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:23:23] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:23:28,257: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:23:28] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:23:33,267: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:23:33] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
> 2016-10-04 09:23:38,278: INFO    werkzeug:    127.0.0.1 - - [04/Oct/2016 09:23:38] "GET /dashboard/activity/4 HTTP/1.1" 428 -
>
>
>
> And here the output from the running server in the bash:
>
> 2016-10-04 09:21:18,214: ERROR	pgadmin:	Failed to execute query (execute_scalar) for the server #4 - DB:postgres (Query-id: 8568684):
> Error Message:FEHLER:  unbekannter Konfigurationsparameter »bytea_output«
>
> Exception in thread Thread-346:
> Traceback (most recent call last):
>   File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
>     self.run()
>   File "/usr/lib/python2.7/threading.py", line 763, in run
>     self.__target(*self.__args, **self.__kwargs)
>   File "/usr/lib/python2.7/SocketServer.py", line 596, in process_request_thread
>     self.handle_error(request, client_address)
>   File "/usr/lib/python2.7/SocketServer.py", line 593, in process_request_thread
>     self.finish_request(request, client_address)
>   File "/usr/lib/python2.7/SocketServer.py", line 334, in finish_request
>     self.RequestHandlerClass(request, client_address, self)
>   File "/usr/lib/python2.7/SocketServer.py", line 649, in __init__
>     self.handle()
>   File "/usr/local/lib/python2.7/dist-packages/werkzeug/serving.py", line 200, in handle
>     rv = BaseHTTPRequestHandler.handle(self)
>   File "/usr/lib/python2.7/BaseHTTPServer.py", line 340, in handle
>     self.handle_one_request()
>   File "/usr/local/lib/python2.7/dist-packages/werkzeug/serving.py", line 235, in handle_one_request
>     return self.run_wsgi()
>   File "/usr/local/lib/python2.7/dist-packages/werkzeug/serving.py", line 177, in run_wsgi
>     execute(self.server.app)
>   File "/usr/local/lib/python2.7/dist-packages/werkzeug/serving.py", line 165, in execute
>     application_iter = app(environ, start_response)
>   File "/usr/local/lib/python2.7/dist-packages/flask/app.py", line 2000, in __call__
>     return self.wsgi_app(environ, start_response)
>   File "/usr/local/lib/python2.7/dist-packages/flask/app.py", line 1991, in wsgi_app
>     response = self.make_response(self.handle_exception(e))
>   File "/usr/local/lib/python2.7/dist-packages/flask/app.py", line 1567, in handle_exception
>     reraise(exc_type, exc_value, tb)
>   File "/usr/local/lib/python2.7/dist-packages/flask/app.py", line 1988, in wsgi_app
>     response = self.full_dispatch_request()
>   File "/usr/local/lib/python2.7/dist-packages/flask/app.py", line 1641, in full_dispatch_request
>     rv = self.handle_user_exception(e)
>   File "/usr/local/lib/python2.7/dist-packages/flask/app.py", line 1544, in handle_user_exception
>     reraise(exc_type, exc_value, tb)
>   File "/usr/local/lib/python2.7/dist-packages/flask/app.py", line 1639, in full_dispatch_request
>     rv = self.dispatch_request()
>   File "/usr/local/lib/python2.7/dist-packages/flask/app.py", line 1625, in dispatch_request
>     return self.view_functions[rule.endpoint](**req.view_args)
>   File "/usr/local/lib/python2.7/dist-packages/flask/views.py", line 84, in view
>     return self.dispatch_request(*args, **kwargs)
>   File "/usr/local/lib/python2.7/dist-packages/pgadmin4/pgadmin/browser/utils.py", line 235, in dispatch_request
>     return method(*args, **kwargs)
>   File "/usr/local/lib/python2.7/dist-packages/pgadmin4/pgadmin/browser/server_groups/servers/__init__.py", line 829, in connect
>     server.id, server.name, errmsg
> UnicodeEncodeError: 'ascii' codec can't encode character u'\xbb' in position 45: ordinal not in range(128)
>
>
> I hope you can follow me an find my mistake.
>
> Many thanks in advance,
>
> Ralph Ryl
>
>
>
> Am 03.10.2016 um 06:47 schrieb Fahar Abbas:
>
> Hi Ralph,
>
> Can you please share the exact steps and *pgAdmin4.log* file location
> under /home/fahar  for Linux and in Windows %AppData% with the team so they
> can investigate the actual problem?
>
> Regards,
>
>
>> Tel:  +49 3334 3820-347 <%2B49%203334%203820-347>
>> Fax:  +49 3334 3820-354 <%2B49%203334%203820-354>

-- 
Syed Fahar Abbas
Quality Management Group

EnterpriseDB Corporation

---

From: Ashesh Vashi <[email-masked]>
Date: Tue, 4 Oct 2016 13:17:31 +0530

>> matter if i save it) and show an message like "Connection to the server has

Looks like - pgAdmin 4 (indirectly the psycopg2 driver) is using very old
version of libpq.

Can you please upgrade the libpq on the system?
I will be able to suggest "how to upgrade on libpq", only if you can give
information about the operating system?

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com/>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>