Subject: pgAdmin4 v4.10 candidate builds

From: Akshay Joshi <[email-masked]>
Date: Fri, 28 Jun 2019 11:21:33 -0400

Hi All,

Due to an showstopper issue found in pgAdmin v4.9, we will have to release
pgAdmin4 v4.10 early. Candidate builds and source can be found at
https://developer.pgadmin.org/builds/2019-06-28-1/

Fahar, can you please verify it for release on Tuesday (2nd July).
-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Fahar Abbas <[email-masked]>
Date: Tue, 2 Jul 2019 10:25:36 +0500

Hi,

Here is the showstopper issue for pgadmin4 4.10:

https://redmine.postgresql.org/issues/4421

Kind Regards,

-- 
Fahar Abbas
QMG
EnterpriseDB Corporation
Phone Office: +92-51-835-8874
Phone Direct: +92-51-8466803
Mobile: +92-333-5409707
Skype ID: *live:fahar.abbas*
Website: www.enterprisedb.com

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 2 Jul 2019 16:38:52 +0530

Hi Fahar

We have fixed RM #4421. Candidate builds and source can be found at
https://developer.pgadmin.org/builds/2019-07-02-1/ .
There is some problem with the wheel packages, will check that. Meanwhile
can you please test the builds for upgrade issue.

On Tue, Jul 2, 2019 at 10:55 AM Fahar Abbas <[email-masked]>
wrote:

> On Fri, Jun 28, 2019 at 8:21 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi All,
>>
>> Due to an showstopper issue found in pgAdmin v4.9, we will have to
>> release pgAdmin4 v4.10 early. Candidate builds and source can be found
>> at https://developer.pgadmin.org/builds/2019-06-28-1/
>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 2 Jul 2019 17:31:01 +0530

Hi,

The issue still persists. I have checked the code and found that
CompareVersions(Version, '{#MyAppFullVersion}') = -1, this should be 1 and not
-1.
Attached is the patch.

Sorry for trouble to build again. :/

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 2 Jul 2019 20:13:04 +0530

Thanks patch applied.

On Tue, Jul 2, 2019 at 5:31 PM Aditya Toshniwal <
[email-masked]> wrote:

> CompareVersions(Version, '{#MyAppFullVersion}') = -1, this should be 1
> and not -1.
> Attached is the patch.
>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 2 Jul 2019 21:57:01 +0530

Hi Fahar,

Candidate builds and source can be found at
https://developer.pgadmin.org/builds/2019-07-02-3/
Please verify the upgrade scenario and rest of the testing for the release
on Thursday 4th July.

On Tue, Jul 2, 2019 at 8:13 PM Akshay Joshi <[email-masked]>
wrote:

>> On Tue, Jul 2, 2019 at 4:39 PM Akshay Joshi <
>>> There is some problem with the wheel packages, will check that.
>>> Meanwhile can you please test the builds for upgrade issue.
>>>
>>> On Tue, Jul 2, 2019 at 10:55 AM Fahar Abbas <
>>> [email-masked]> wrote:
>>>
>>>> Hi,
>>>>
>>>>> release pgAdmin4 v4.10 early. Candidate builds and source can be
>>>>> found at https://developer.pgadmin.org/builds/2019-06-28-1/
>>>>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Fahar Abbas <[email-masked]>
Date: Thu, 4 Jul 2019 16:58:32 +0500

One Round of testing has been completed for pgadmin4 4.10  and we can
release it.