Subject: pgAdmin 4 commit: Sporadically crashes on Windows when exit. Fixes #317

From: Akshay Joshi <[email-masked]>
Date: Thu, 15 Mar 2018 07:57:10 +0000

Sporadically crashes on Windows when exit. Fixes #3177
  1) Shutdown the python server properly.
  2) Disabled "Shutdown server" menu till server is not successfully started.

Initial patch sent by Maxim, modified by Akshay Joshi.

Branch
------
master

Details
-------
https://git.postgresql.org/gitweb?p=pgadmin4.git;a=commitdiff;h=54b1a79cb6f90ac9b26db57e616dc750fb2c6b54
Author: Maxim Zakharov <[email-masked]>

Modified Files
--------------
runtime/Server.cpp           | 11 +++++++++++
runtime/Server.h             |  3 +++
runtime/TrayIcon.cpp         | 11 +++++++++++
runtime/TrayIcon.h           |  4 ++++
runtime/pgAdmin4.cpp         | 46 ++++++++++++++++++++++++++++++++++++++++++++
runtime/pgAdmin4.h           |  1 +
web/pgadmin/misc/__init__.py | 16 ++++++++++++++-
7 files changed, 91 insertions(+), 1 deletion(-)

---

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 15 Mar 2018 16:03:32 +0530

Hi Akshay,

Given commit introduce PEP8 issue, PFA minor patch to fix the issue.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

On Thu, Mar 15, 2018 at 1:27 PM, Akshay Joshi <[email-masked]
> wrote:

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 15 Mar 2018 16:14:17 +0530

Thanks patch applied

On Thu, Mar 15, 2018 at 4:03 PM, Murtuza Zabuawala <
[email-masked]> wrote:

> On Thu, Mar 15, 2018 at 1:27 PM, Akshay Joshi <
> [email-masked]> wrote:
>
>> https://git.postgresql.org/gitweb?p=pgadmin4.git;a=commitdif
>> f;h=54b1a79cb6f90ac9b26db57e616dc750fb2c6b54

-- 
*Akshay Joshi*

*Sr. Software Architect *

*Phone: +91 20-3058-9517Mobile: +91 976-788-8246*