Subject: [pgAdmin4][RM 5271] To change the switch control colors

From: Murtuza Zabuawala <[email-masked]>
Date: Wed, 18 Mar 2020 12:43:23 +0530

Hello,

As per discussion with Chethana, We need to make switch box color change
for light and dark theme, Color details provided by Chethana is updated on
ticket.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 18 Mar 2020 13:51:50 +0530

Hi Murtuza,

Why do we need to add new variable swith-ternary ? What was the issue you
were facing ?

-- 
Thanks and Regards,
Aditya Toshniwal
pgAdmin Hacker | Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Chethana Kumar <[email-masked]>
Date: Wed, 18 Mar 2020 14:06:48 +0530

Hi Murtuza,

The changes are already incorporated so no worries :)

Thanks,

---
Chethana kumar

-- 
Chethana Kumar
Principal UI/UX Designer
EnterpriseDB Corporation

The Postgres Database Company

P: +91 86981 57146
www.enterprisedb.com

---

From: Murtuza Zabuawala <[email-masked]>
Date: Wed, 18 Mar 2020 14:07:42 +0530

Hi Aditya,

> Why do we need to add new variable swith-ternary ? What was the issue you
Just to make both class names consistent, I missed to git add those changes
in the patch in which I removed the ternary scss variable.

---

From: Murtuza Zabuawala <[email-masked]>
Date: Wed, 18 Mar 2020 14:12:39 +0530

Hi Chethana,

No it is not, As per current dark theme implementation we have used primary
color '#1a522b' for switch but the color you suggested is '#43A047' for
both theme.

---

From: Chethana Kumar <[email-masked]>
Date: Wed, 18 Mar 2020 14:23:57 +0530

Let us discuss on a call for better clarity and the conclusion part we can
put it on mail.

---
Chethana kumar

On Wed, Mar 18, 2020 at 2:12 PM Murtuza Zabuawala <
[email-masked]> wrote:

> Hi Chethana,
>
> No it is not, As per current dark theme implementation we have used
> primary color '#1a522b' for switch but the color you suggested is '#43A047'
> for both theme.
>
>
> --
> Regards,
> Murtuza Zabuawala

-- 
Chethana Kumar
Principal UI/UX Designer
EnterpriseDB Corporation

P: +91 86981 57146
www.enterprisedb.com

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 18 Mar 2020 14:26:44 +0530

Hi Murtuza/Chethana,

Irrespective of what color you suggest, there is no need to add new
variables for switch buttons. It should use success for on and ternary for
off.
Having a separate green color for each and every control is absurd. If the
green changes, it should change for all.

On Wed, Mar 18, 2020 at 2:24 PM Chethana Kumar <
[email-masked]> wrote:

>>>> As per discussion with Chethana, We need to make switch box color
>>>> change for light and dark theme, Color details provided by Chethana is
>>>> updated on ticket.
>>>>
>>>>
>>>> --
>>>> Regards,
>>>> Murtuza Zabuawala

---

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 19 Mar 2020 12:10:17 +0530

Hello,

PFA updated patch with new colors provided by Chethana, As discussed we
will be using the same primary success color in both theme so we don't have
add new variable.

On Wed, Mar 18, 2020 at 2:27 PM Aditya Toshniwal <
[email-masked]> wrote:

>> Let us discuss on a call for better clarity and the conclusion part we
>> can put it on mail.
>>
>> ---
>> Chethana kumar
>>

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 19 Mar 2020 12:33:14 +0530

Hi Murtuza,

The patch looks good to me.

On Thu, Mar 19, 2020 at 12:10 PM Murtuza Zabuawala <
[email-masked]> wrote:

>> Having a separate green color for each and every control is absurd. If
>> the green changes, it should change for all.
>>

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 19 Mar 2020 13:59:47 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*