Subject: pgAdmin4 form control error icon position change

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 21 Mar 2018 14:28:11 +0530

*Hi Team,*

This is regarding the position of error icon of a pgAdmin form control.
Below are the screenshots. As we can see, the error icon is overlapping the
control buttons like the drop down button, spinner up down buttons, etc.

We propose that we can move the error icon to the front of the label of the
form control. Below are screenshots.

Attached is the patch for the above changes.
Kindly review.
-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB Software Solutions
Pune | Mob - 8055837949
diff --git a/web/pgadmin/static/css/bootstrap.overrides.css b/web/pgadmin/static/css/bootstrap.overrides.css
index d2936a7..2ab44f0 100755
--- a/web/pgadmin/static/css/bootstrap.overrides.css
+++ b/web/pgadmin/static/css/bootstrap.overrides.css
@@ -269,7 +269,7 @@ iframe {
 
 .control-label {
     margin: 0px;
-    padding: 5px;
+    padding: 5px 25px 5px 5px;
     display: inline-block;
     vertical-align: middle;
 }
diff --git a/web/pgadmin/static/css/pgadmin.css b/web/pgadmin/static/css/pgadmin.css
index 6c1002c..666140e 100644
--- a/web/pgadmin/static/css/pgadmin.css
+++ b/web/pgadmin/static/css/pgadmin.css
@@ -732,7 +732,7 @@ lgg-el-container[el=md] .pg-el-lg-8,
   padding-top: 6px;
   padding-bottom: 6px;
   padding-left: 5px;
-  padding-right: 5px;
+  padding-right: 25px;
   display: inline-block;
   vertical-align: middle;
   min-height: 28px;
diff --git a/web/pgadmin/static/scss/_backform.overrides.scss b/web/pgadmin/static/scss/_backform.overrides.scss
index 2aa9460..b22c55a 100644
--- a/web/pgadmin/static/scss/_backform.overrides.scss
+++ b/web/pgadmin/static/scss/_backform.overrides.scss
@@ -8,14 +8,14 @@
     color: #d0021b;
   }
 
-  .pgadmin-controls:before {
+  .control-label:before {
     font: normal normal normal 16px/1 FontAwesome;
     content: "\f071";
     text-decoration: inherit;
     position: absolute;
     color: #d0021b;
-    right: 15px;
-    padding-top: 10px;
+    right: 6px;
+    padding-top: 6px;
     z-index: 1;
   }
 }

---

From: Murtuza Zabuawala <[email-masked]>
Date: Wed, 21 Mar 2018 14:51:51 +0530

Hello Aditya,

Could you please create new RM
<https://redmine.postgresql.org/projects/pgadmin4> for the issue, so that
we can keep track of changes, It will be difficult for us to keep track of
email for the details.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

On Wed, Mar 21, 2018 at 2:28 PM, Aditya Toshniwal <
[email-masked]> wrote:

> We propose that we can move the error icon to the front of the label of
> the form control. Below are screenshots.
>
>
>
>

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 21 Mar 2018 15:04:24 +0530

Created - https://redmine.postgresql.org/issues/3226

On Wed, Mar 21, 2018 at 2:51 PM, Murtuza Zabuawala <
[email-masked]> wrote:

> we can keep track of changes, It will be difficult for us to keep track
> of email for the details.
>
> --
> Regards,
> Murtuza Zabuawala
> On Wed, Mar 21, 2018 at 2:28 PM, Aditya Toshniwal <aditya.toshniwal@
> enterprisedb.com> wrote:
>
>>
>> *Hi Team,*
>>

---

From: Dave Page <[email-masked]>
Date: Fri, 23 Mar 2018 09:57:53 +0000

Thanks Aditya, patch applied.

On Wed, Mar 21, 2018 at 9:34 AM, Aditya Toshniwal <
[email-masked]> wrote:

> On Wed, Mar 21, 2018 at 2:51 PM, Murtuza Zabuawala <murtuza.zabuawala@
> enterprisedb.com> wrote:
>
>> Hello Aditya,
>>
>> <https://redmine.postgresql.org/projects/pgadmin4> for the issue, so
>> that we can keep track of changes, It will be difficult for us to keep
>> track of email for the details.
>>
>> --
>> Regards,
>> Murtuza Zabuawala
>>> Pune | Mob - 8055837949 <(805)%20583-7949>
>>>
>>
>>
>
>
> --
> Thanks and Regards,
> Aditya Toshniwal
> Pune | Mob - 8055837949 <(805)%20583-7949>
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company