Subject: [pgAdmin][RM6231]- Add OS, Browser details in pgAdmin About us pop-up

From: Pradip Parkale <[email-masked]>
Date: Fri, 21 May 2021 14:22:55 +0530

Hi Hackers,

Please find the attached patch for #6231. I have added OS, NW.js, browser
details, and some server configuration in the About pgAdmin pop-up.

Server configuration won't be visible to the non-admin users in server mode.
-- 
Thanks & Regards,
Pradip Parkale
Software Engineer | EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 24 May 2021 16:44:53 +0530

Hi Pradip

Following are the review comments:

   - Following labels should be changed
      - Browser Details -> Browser
      - OS -> Operating System
      - Config DB -> pgAdmin Database File
   - Server Configuration Text Area should be *readonly* and it should have
   a "col-sm-9" class instead of "col-sm-3".
   - If the user resizes the About dialog then instead of showing blank
   space can we automatically resize the Server configuration text area?
   - The height of the About dialog in the Server mode should be less as we
   are not showing "Server Configuration".
   - In Runtime, we should merge the 'Browser details' in 'NW.js version'
   like *0.51.2 (Chromium 89.0.4389.114)* OR at least prefix 'Chromium'
   before the version in the 'Browser details'.
   - Found string difference in OS details for Runtime and Desktop mode.
      - OSX: "Intel Mac OS X 10_15_7" in Runtime, while "Mac OS X 10.15.7"
      in Dekstop mode.
      - Windows: "Win64" in Runtime, while "Windows 10" in Desktop which
      also not correct, I am using "Windows Server 2016".
   - Following issue found on Firefox (First Image) configuration in a
   single line, Safari (Second image) too many scroll bars.

                  .      

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Pradip Parkale <[email-masked]>
Date: Tue, 1 Jun 2021 14:02:48 +0530

Hi Akshay,

Please find an updated patch.

On Mon, May 24, 2021 at 4:45 PM Akshay Joshi <[email-masked]>
wrote:

> Done.

>
>    - Server Configuration Text Area should be *readonly* and it should
>    have a "col-sm-9" class instead of "col-sm-3".
>
> Done.

> Done.

>
>    - The height of the About dialog in the Server mode should be less as
>    we are not showing "Server Configuration".
>
> Done.

> Done.

>       - OSX: "Intel Mac OS X 10_15_7" in Runtime, while "Mac OS X
>       10.15.7" in Dekstop mode.
> Done.

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 1 Jun 2021 20:48:37 +0530

Thanks, patch applied.

On Tue, Jun 1, 2021 at 2:03 PM Pradip Parkale <
[email-masked]> wrote:

> On Mon, May 24, 2021 at 4:45 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Pradip
>>
>>    - In Runtime, we should merge the 'Browser details' in 'NW.js
>>    version' like *0.51.2 (Chromium 89.0.4389.114)* OR at least prefix
>>    'Chromium' before the version in the 'Browser details'.
>>
>> Done.
>
>>
>>> Please find the attached patch for #6231. I have added OS, NW.js,
>>> browser details, and some server configuration in the About pgAdmin pop-up.
>>>

---

From: Pradip Parkale <[email-masked]>
Date: Fri, 4 Jun 2021 17:33:25 +0530

Hi Akshay,

Please find the updated patch. I have fixed the OS details issue for Linux,
MacOS big sur.

On Tue, Jun 1, 2021 at 8:48 PM Akshay Joshi <[email-masked]>
wrote:

>>>    - The height of the About dialog in the Server mode should be less
>>>    as we are not showing "Server Configuration".
>>>
>>> Done.
>>
>>>
>>>       - Windows: "Win64" in Runtime, while "Windows 10" in Desktop
>>>       which also not correct, I am using "Windows Server 2016".

---

From: Murtuza Zabuawala <[email-masked]>
Date: Fri, 4 Jun 2021 19:03:46 +0530

Hello,

I want to propose a suggestion here, If we can display configuration data
in category/tab like below then it will make sense for the user (instead of
dumping everthing in one single textbox randomly from config file)

SMTP
 - config1=value1
 - config2=value2
 - config3=value3 ...
AUTHENTICATION
 - KERBERSOE
   - config1=value1
   - config2=value2
   - config3=value3 ...
 - LDAP
   - config1=value1
   - config2=value2
   - config3=value3 ...
SECURITY
 - config1=value1
 - config2=value2
 - config3=value3 ...

Regards,
Murtuza

On Fri, Jun 4, 2021 at 5:33 PM Pradip Parkale <
[email-masked]> wrote:

> Hi Akshay,
>
> Please find the updated patch. I have fixed the OS details issue for
> Linux, MacOS big sur.
>
>>>>    - If the user resizes the About dialog then instead of showing
>>>>    blank space can we automatically resize the Server configuration text area?
>>>>
>>>> Done.
>>>
>>>>

---

From: Dave Page <[email-masked]>
Date: Fri, 4 Jun 2021 14:53:26 +0100

Hi

> dumping everthing in one single textbox randomly from config file)

It would, but it's not really worth the effort. This is really intended as
debugging info the user can just copy/paste into an email to us.

>> On Tue, Jun 1, 2021 at 8:48 PM Akshay Joshi <
>>>>>    - Server Configuration Text Area should be *readonly* and it
>>>>>    should have a "col-sm-9" class instead of "col-sm-3".
>>>>>
>>>>> Done.
>>>>
>>>>>
>>>>>    - Following issue found on Firefox (First Image) configuration in
>>>>>    a single line, Safari (Second image) too many scroll bars.
>>>>>
>>>>> Done.
>>>>
>>>>>                   .      
>>>>>

-- 
Dave Page
VP, Chief Architect, Database Infrastructure
Blog: https://www.enterprisedb.com/dave-page
Twitter: @pgsnake

EDB: https://www.enterprisedb.com

---

From: Murtuza Zabuawala <[email-masked]>
Date: Fri, 4 Jun 2021 19:44:20 +0530

Hi Dave,

> debugging info the user can just copy/paste into an email to us.

If it is for debugging purpose only then can we just place a "Copy
configuration" button and hide this textbox, by clicking on the button will
copy all the pgadmin4 configuration on the user's clipboard and can avoid
clutter from the about window.

>>>>>>    - The height of the About dialog in the Server mode should be
>>>>>>    less as we are not showing "Server Configuration".
>>>>>>
>>>>>> Done.
>>>>>
>>>>>>
>>>>>>    version' like *0.51.2 (Chromium 89.0.4389.114)* OR at least
>>>>>>    prefix 'Chromium' before the version in the 'Browser details'.
>>>>>>
>>>>>> Done.
>>>>>
>>>>>>

---

From: Dave Page <[email-masked]>
Date: Fri, 4 Jun 2021 15:39:14 +0100

On Fri, Jun 4, 2021 at 3:14 PM Murtuza Zabuawala <
[email-masked]> wrote:

>>> I want to propose a suggestion here, If we can display configuration
>>> data in category/tab like below then it will make sense for the user
>>> (instead of dumping everthing in one single textbox randomly from
>>> config file)
>>>
>>> SMTP
>>>  - config1=value1
>>>  - config2=value2
>>>  - config3=value3 ...
>>> AUTHENTICATION
>>>  - KERBERSOE
>>>    - config1=value1
>>>    - config2=value2
>>>    - config3=value3 ...
>>>  - LDAP
>>>    - config1=value1
>>>    - config2=value2
>>>    - config3=value3 ...
>>> SECURITY
>>>  - config1=value1
>>>  - config2=value2
>>>  - config3=value3 ...
>>>
>>
>> It would, but it's not really worth the effort. This is really intended
>> as debugging info the user can just copy/paste into an email to us.
>>
>

It's still useful to read it occasionally IMHO.

>>>>>>>    - Following issue found on Firefox (First Image) configuration
>>>>>>>    in a single line, Safari (Second image) too many scroll bars.
>>>>>>>
>>>>>>> Done.
>>>>>>
>>>>>>>                   .      
>>>>>>>

---

From: Pradip Parkale <[email-masked]>
Date: Fri, 11 Jun 2021 19:19:57 +0530

Hi Akshay,

Please find the attached patch for #6231.I have fixed all review comments
given in the team.

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 11 Jun 2021 19:40:16 +0530

Thanks, the patch applied.

On Fri, Jun 11, 2021 at 7:20 PM Pradip Parkale <
[email-masked]> wrote:

>>>>>>>>>       - Windows: "Win64" in Runtime, while "Windows 10" in
>>>>>>>>>       Desktop which also not correct, I am using "Windows Server 2016".

---

From: Pradip Parkale <[email-masked]>
Date: Thu, 24 Jun 2021 21:04:02 +0530

Hi Akshay,

Please find the attached patch.'Mail_Password' was visible in server
configuration.I removed that now.

On Fri, Jun 11, 2021 at 7:40 PM Akshay Joshi <[email-masked]>
wrote:

>>>>> It would, but it's not really worth the effort. This is really
>>>>> intended as debugging info the user can just copy/paste into an email to us.
>>>>>
>>>>
>>>>>>>>>>    - If the user resizes the About dialog then instead of
>>>>>>>>>>    showing blank space can we automatically resize the Server configuration
>>>>>>>>>>    text area?
>>>>>>>>>>
>>>>>>>>>> Done.
>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>       - OSX: "Intel Mac OS X 10_15_7" in Runtime, while "Mac OS
>>>>>>>>>>       X 10.15.7" in Dekstop mode.
>>>>>>>>>>    - Following issue found on Firefox (First Image)
>>>>>>>>>>    configuration in a single line, Safari (Second image) too many scroll bars.
>>>>>>>>>>
>>>>>>>>>> Done.
>>>>>>>>>
>>>>>>>>>>                   .      
>>>>>>>>>>
>>>>>>>>>>> Please find the attached patch for #6231. I have added OS,
>>>>>>>>>>> NW.js, browser details, and some server configuration in the About pgAdmin
>>>>>>>>>>> pop-up.
>>>>>>>>>>>

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 25 Jun 2021 11:39:43 +0530

On Thu, Jun 24, 2021 at 9:04 PM Pradip Parkale <
[email-masked]> wrote:

> On Fri, Jun 11, 2021 at 7:40 PM Akshay Joshi <
>>> Please find the attached patch for #6231.I have fixed all review
>>> comments given in the team.
>>>
>>>>>>>> Please find the updated patch. I have fixed the OS details issue
>>>>>>>> for Linux, MacOS big sur.
>>>>>>>>
>>>>>>>>>>>    - The height of the About dialog in the Server mode should
>>>>>>>>>>>    be less as we are not showing "Server Configuration".
>>>>>>>>>>>
>>>>>>>>>>> Done.
>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>    - In Runtime, we should merge the 'Browser details'
>>>>>>>>>>>    in 'NW.js version' like *0.51.2 (Chromium 89.0.4389.114)* OR
>>>>>>>>>>>    at least prefix 'Chromium' before the version in the 'Browser details'.
>>>>>>>>>>>
>>>>>>>>>>> Done.
>>>>>>>>>>
>>>>>>>>>>>