Subject: [pgAdmin4][RM#3139] Create proper template path if Windows

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 12 Mar 2018 19:45:36 +0530

Hi,

PFA patch to correct the template path generation logic incase of Windows
system.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Dave Page <[email-masked]>
Date: Mon, 12 Mar 2018 20:41:27 -0400

Hi

> PFA patch to correct the template path generation logic incase of Windows

Seems like it would be better to fix it the other way round to me - e.g.
update the template loader to use os.path.join.

Any reason not to do that?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Murtuza Zabuawala <[email-masked]>
Date: Tue, 13 Mar 2018 10:02:01 +0530

Hi Dave,

We are not joining template path with os.path.join because we are passing
prefix paths in render_template(..) at many places,
we are passing them as below,

Some of examples,

render_template(
    "exclusion_constraint/js/exclusion_constraint.js",
    _=_
),

recovery_check_sql = render_template(
        "connect/sql/#{0}#/check_recovery.sql".format(postgres_version))

sql = render_template(
    "/servers/sql/#{0}#/stats.sql".format(manager.version),
    conn=conn, _=gettext
)

sql = render_template(
    "/".join([self.template_path, 'create.sql']),
    data=data, conn=self.conn
)

def csssnippets(self):
    """
    Returns a snippet of css to include in the page
    """
    snippets = [render_template("css/servers.css")]

So again it will conflict if use os.path.join, To make it consistent with
render_template(...) and VersionedTemplateLoader(..) class we opt'd for
this mechanism.

On Tue, Mar 13, 2018 at 6:11 AM, Dave Page <[email-masked]> wrote:

> Hi
>
> On Mon, Mar 12, 2018 at 10:15 AM, Murtuza Zabuawala <murtuza.zabuawala@
> enterprisedb.com> wrote:
>
>> Hi,
>>

---

From: Dave Page <[email-masked]>
Date: Tue, 13 Mar 2018 07:58:17 -0400

OK, thanks. Patch applied.

On Tue, Mar 13, 2018 at 12:32 AM, Murtuza Zabuawala <
[email-masked]> wrote:

>>> PFA patch to correct the template path generation logic incase of
>>> Windows system.
>>>
>>

---

From: Dave Page <[email-masked]>
Date: Tue, 13 Mar 2018 08:50:36 -0400

And... reverted. It seems this makes Jenkins very unhappy.

On Tue, Mar 13, 2018 at 7:58 AM, Dave Page <[email-masked]> wrote:

> On Tue, Mar 13, 2018 at 12:32 AM, Murtuza Zabuawala <murtuza.zabuawala@
> enterprisedb.com> wrote:
>
>> Hi Dave,
>>

---

From: Murtuza Zabuawala <[email-masked]>
Date: Tue, 13 Mar 2018 18:24:28 +0530

Hi Dave,

I have already replied on another thread regarding the failure of these
tests, Joao has already sent a patch for the same.

On Tue, Mar 13, 2018 at 6:20 PM, Dave Page <[email-masked]> wrote:

>>> We are not joining template path with os.path.join because we are
>>> passing prefix paths in render_template(..) at many places,
>>> So again it will conflict if use os.path.join, To make it consistent
>>> with render_template(...) and VersionedTemplateLoader(..) class we
>>> opt'd for this mechanism.
>>>
>>>
>>> --
>>> Regards,
>>> Murtuza Zabuawala
>>>> Seems like it would be better to fix it the other way round to me -
>>>> e.g. update the template loader to use os.path.join.
>>>>

---

From: Murtuza Zabuawala <[email-masked]>
Date: Tue, 13 Mar 2018 18:57:04 +0530

Hi Dave,

Please find updated patch which Joao sent along with RM#3139 fix.

---

From: Dave Page <[email-masked]>
Date: Tue, 13 Mar 2018 12:45:27 -0400

Thanks, applied.

On Tue, Mar 13, 2018 at 9:27 AM, Murtuza Zabuawala <
[email-masked]> wrote:

> On Tue, Mar 13, 2018 at 6:24 PM, Murtuza Zabuawala <murtuza.zabuawala@
> enterprisedb.com> wrote:
>
>> Hi Dave,
>>