Subject: pgAdmin 4 commit: Use 'sys.executable' to get the absolute path of the

From: Akshay Joshi <[email-masked]>
Date: Tue, 09 Feb 2021 10:58:27 +0000

Use 'sys.executable' to get the absolute path of the executable binary for the Python interpreter instead of existing complex logic.

Branch
------
master

Details
-------
https://git.postgresql.org/gitweb?p=pgadmin4.git;a=commitdiff;h=53724675697ccdf34b8e6a5da21e9b4fc4d612c5

Modified Files
--------------
web/pgadmin/misc/bgprocess/processes.py | 89 +--------------------------------
1 file changed, 1 insertion(+), 88 deletions(-)

---

From: Murtuza Zabuawala <[email-masked]>
Date: Tue, 9 Feb 2021 16:51:15 +0530

Hi,

It will break the WSGI.

--
Regards,
Murtuza Zabuawala
*EDB*
*POWER TO POSTGRES*
https://www.edbpostgres.com

On Tue, Feb 9, 2021 at 4:28 PM Akshay Joshi <[email-masked]>
wrote:

> Use 'sys.executable' to get the absolute path of the executable binary for
> the Python interpreter instead of existing complex logic.
>
> Branch
> ------
> master
>
> Details
> -------
>

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 9 Feb 2021 19:37:16 +0530

Hi Murtuza/Hackers

> It will break the WSGI.

   I have tested pgAdmin4 using the following combination:

   - Python wheel package + Apache (WSGI) on Ubuntu 18.04 (Fresh VM)
   - APT https://www.pgadmin.org/download/pgadmin-4-apt/  on Ubuntu 18.04
   (Fresh VM)

   I have made the code changes after installation, use sys.executable, and
then restart the apache in both the above test scenario. All the
utilities(Backup, Maintainance, etc...) working absolutely fine. Please
refer to the below screenshot

   Am I missing some scenario? If any specific test scenario that I missed
please let me know so that I'll figure out some solution.

>> Use 'sys.executable' to get the absolute path of the executable binary
>> for the Python interpreter instead of existing complex logic.
>>
>> Branch
>> ------
>> master
>>
>> Details
>> -------
>>

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Murtuza Zabuawala <[email-masked]>
Date: Tue, 9 Feb 2021 20:15:28 +0530

Hi,

On Tue, Feb 9, 2021 at 7:37 PM Akshay Joshi <[email-masked]>
wrote:

>    I have made the code changes after installation, use sys.executable,
> and then restart the apache in both the above test scenario. All the

I don't remember the exact scenario/steps but AFAIR we rewrote that logic
to handle scenario when we run pgAdmin4 under WSGI and/or on Windows, It
was using the wrong python path to execute the process executor.
-- Murtuza

>> On Tue, Feb 9, 2021 at 4:28 PM Akshay Joshi <
>> [email-masked]> wrote:
>>