Subject: PATCH: To fix the performance of delete operation (pgAdmin4)

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 15 Sep 2016 15:38:09 +0530

Hi,

PFA patch to fix the issue of slow performance while deleting rows from
grid.
RM#1696

*Issue:*
As per logic implemented for Backgrid, we were deleting individual rows,
means If user selects 100 rows to delete then we were rendering sql
template 100 times to generate sql for each individual rows and then
execute all 100 delete statements one by one due to which we were getting
poor performance.

Please review.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 16 Sep 2016 11:01:06 +0100

Can you rebase this please?

Thanks.

On Thu, Sep 15, 2016 at 11:08 AM, Murtuza Zabuawala
<[email-masked]> wrote:
> Issue:
> means If user selects 100 rows to delete then we were rendering sql template
> 100 times to generate sql for each individual rows and then execute all 100
> delete statements one by one due to which we were getting poor performance.
>
> Please review.
>
> --
> Regards,
> Murtuza Zabuawala

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Murtuza Zabuawala <[email-masked]>
Date: Fri, 16 Sep 2016 17:04:18 +0530

Hi Dave,

Please find updated patch.

Regards,
Murtuza

On Fri, Sep 16, 2016 at 3:31 PM, Dave Page <[email-masked]> wrote:

> template

---

From: Dave Page <[email-masked]>
Date: Fri, 16 Sep 2016 16:48:05 +0100

Thanks - committed with a couple of changes:

- I re-formatted the SQL
- s/lables/labels

Awesome speedup BTW - deleting 25K rows went from >10 minutes to
virtually instant. Good work.