Subject: [pgAdmin4][RM#4278] Backgrid loses the focus when PasswordCell opens autocomplete suggestion list

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 20 May 2019 12:31:27 +0530

Hi,

PFA minor patch to fix the issue with Backgrid PasswordCell.
In the Backgrid PasswordCell, The browser's autocomplete functionality
opens up the saved password list which cause the Backgrid to lose focus
from the current cell and causes issue in keyboard navigation.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Dave Page <[email-masked]>
Date: Mon, 20 May 2019 10:02:11 +0100

Hi

> from the current cell and causes issue in keyboard navigation.

This is a much bigger issue - please see the previous discussion at
https://www.postgresql.org/message-id/flat/CAFOhELfwsvHDr-jE9V3xZnZugf2LF%2BRbmELxCO2NcrTqYmeS_Q%40mail.gmail.com#931bda161445351150106352b66ced01

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 20 May 2019 16:23:34 +0530

Hi Dave,

Yes, that's is annoying for me too to debug that issue :)

And now setting it "new-password" does not cause the Backgrid to lose
focus, As of now I can see the only workaround that worked for me in all
browsers, I've tested in latest Chrome/FF & IE11.

---

From: Dave Page <[email-masked]>
Date: Mon, 20 May 2019 13:35:17 +0100

Hi

OK, well this won't hurt anyway, so patch applied.

Thanks!