Subject: [pgAdmin4][RM#3319] Fix the cancel query button glitch in query tool

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 2 Jul 2018 10:28:52 +0530

Hi,

PFA patch to fix the issue where cancel button remains enabled even after
the query execution completes, I have moved the enable/disable logic for
that button with rest of the buttons in '*disable_tool_buttons*' method &
removed tests which are not required as we are already testing '
*disable_tool_buttons*' method.

*I had to fix it coz it was annoying me :)*

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Dave Page <[email-masked]>
Date: Mon, 2 Jul 2018 15:37:11 +0100

Thanks, patch applied.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company