Subject: PATCH: To fix salt generation in session.py

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 11 Jul 2016 12:41:56 +0530

Hi,

With latest pull session.py fails with below error with python3 because in
python3 strings 'lowercase' method has been renamed to 'ascii_lowercase',
PFA patch to fix the issue.

Issue:
----------
*  File "../pgadmin4/web/pgadmin/utils/session.py", line 59, in sign*
*    self.randval = ''.join(random.sample(string.lowercase+string.digits,
20))*
*AttributeError: module 'string' has no attribute 'lowercase'*

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 11 Jul 2016 12:44:20 +0530

Hi,

Please hold on in this patch, Need additional changes.

---

From: Ashesh Vashi <[email-masked]>
Date: Mon, 11 Jul 2016 16:05:15 +0530

Hi Murtuza,

Can you please test this patch for the same?

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>

On Mon, Jul 11, 2016 at 12:44 PM, Murtuza Zabuawala <
[email-masked]> wrote:

>> With latest pull session.py fails with below error with python3 because
>> in python3 strings 'lowercase' method has been renamed to
>> 'ascii_lowercase', PFA patch to fix the issue.
>>
>> Issue:
>> ----------

---

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 11 Jul 2016 16:30:53 +0530

Hi,

Tested, I'm able to login now.

Thanks,
Murtuza

On Mon, Jul 11, 2016 at 4:05 PM, Ashesh Vashi <[email-masked]
> wrote:

>>> *    self.randval =
>>> ''.join(random.sample(string.lowercase+string.digits, 20))*

---

From: Ashesh Vashi <[email-masked]>
Date: Mon, 11 Jul 2016 16:33:09 +0530

I've committed the patch.
Thanks for testing it.

--

Thanks & Regards,

Ashesh Vashi

On Mon, Jul 11, 2016 at 4:30 PM, Murtuza Zabuawala <
[email-masked]> wrote:

> On Mon, Jul 11, 2016 at 4:05 PM, Ashesh Vashi <
> [email-masked]> wrote:
>
>> Hi Murtuza,
>>